summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-24 07:24:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-24 10:23:12 +0200
commit2d4283b7486c6dea075f084da0599a5e573e708c (patch)
tree15e0ffc2e5c886f660cca96448e53c4fe2ea9e66 /dev-python/flask-security
parentpackage.mask: last-rite dev-java/jsr101 (diff)
downloadgentoo-2d4283b7486c6dea075f084da0599a5e573e708c.tar.gz
gentoo-2d4283b7486c6dea075f084da0599a5e573e708c.tar.bz2
gentoo-2d4283b7486c6dea075f084da0599a5e573e708c.zip
dev-python/flask-security: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/Manifest1
-rw-r--r--dev-python/flask-security/flask-security-4.1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index 5c5bca76fb7f..b44047c47708 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1,2 +1,3 @@
DIST flask-security-3.4.5.gh.tar.gz 348928 BLAKE2B 9890227e9775c4a28fc364affb0bf767407463d514f6dc3cd359dd8a026e8325d943a547f294f6363a276f9e7d97336c526dd45f4549c7cfaff2d6ef9ef0316a SHA512 f9ac7f46b2e1ab7dbb44ba925b01e16304e8f8d6d5d56f4e558d07b80dfffa59f04c2597e17c00a7d7ae11be3a97c78ccf8d79993b7451be4a7f75f85bc89f6f
DIST flask-security-4.0.1.gh.tar.gz 389071 BLAKE2B 38e352dab5fe687211240011d844a1d5f6c0b5fcbb10752960f7ff5de14f5aa2e30ed9bdadda6684a3bc99e176edb7b8937d99322b4c131e22e87b273896c391 SHA512 ea541cb40679432dea67ffc0bc640147c518e07b7e83a01e3beacc156d0a9198a33da3f458a9219b04148c011f1a26f1a4019a216904239efea3b57e65f3cb45
+DIST flask-security-4.1.0.gh.tar.gz 406508 BLAKE2B 84da1a563630e4935fecd616ccb51b2421854b502ce9e5b1c328fef358a2c80946ec1308199cf4dffa4fd07ac65ba104bfb9cdb8956916c5ec3fc39da79472a0 SHA512 b31a48abd2f1ccbc79707b377799adcc8f5530a045437d49d28fa5b47187c98993339a05fac35e4677e46ded99df40b8d8a379f9d36c2b2020456520e99b8de6
diff --git a/dev-python/flask-security/flask-security-4.1.0.ebuild b/dev-python/flask-security/flask-security-4.1.0.ebuild
new file mode 100644
index 000000000000..b9bc75feb4f9
--- /dev/null
+++ b/dev-python/flask-security/flask-security-4.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="
+ https://github.com/Flask-Middleware/flask-security/
+ https://pypi.org/project/Flask-Security-Too/"
+SRC_URI="
+ https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
+ >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
+ >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
+ >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ amd64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
+ arm64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's@--cache-clear@-p no:httpbin@' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ esetup.py compile_catalog
+}