summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-23 16:40:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-23 17:03:14 +0300
commitc385afcf821cd1510ea39abfb95fcf7a187d7ba4 (patch)
tree7e9d0ac2e6acb320291faedf5ed20565610d8152 /dev-python/flask-security
parentdev-python/kaitaistruct: enable py3.10 (diff)
downloadgentoo-c385afcf821cd1510ea39abfb95fcf7a187d7ba4.tar.gz
gentoo-c385afcf821cd1510ea39abfb95fcf7a187d7ba4.tar.bz2
gentoo-c385afcf821cd1510ea39abfb95fcf7a187d7ba4.zip
dev-python/flask-security: enable py3.10
Based on [1], upstream recommend testing on py3.10 without pony. When reviewing pony (to maybe bump), it is base on python's parser module, which was removed on python 3.10 - meaning pony will need a huge rewrite to work on python 3.10. Test suite passes, while all tests depending on pony are just auto skipped on python 3.10 [1] https://github.com/Flask-Middleware/flask-security/commit/5f85daf8ed029f0392c7019a4e6b948226a57c8f Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/flask-security-4.1.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/flask-security/flask-security-4.1.2.ebuild b/dev-python/flask-security/flask-security-4.1.2.ebuild
index a3dce632dd5d..7c01e12dd761 100644
--- a/dev-python/flask-security/flask-security-4.1.2.ebuild
+++ b/dev-python/flask-security/flask-security-4.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Simple security for Flask apps"
@@ -43,11 +43,13 @@ BDEPEND="
>=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
>=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
>=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
- >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
>=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
>=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
>=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
>=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ ' python3_8 python3_9)
amd64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
arm64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
)"