summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-28 20:33:58 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-28 20:37:51 +0100
commit5b8ea5bbb40843dfd21a03a388ccdd94d898516b (patch)
treed2528f6b7fe6ad7e692df34fabcdaeb1bc3d55b7 /dev-python/flask-sqlalchemy
parentdev-tcltk/tkimg: fix symlinks (diff)
downloadgentoo-5b8ea5bbb40843dfd21a03a388ccdd94d898516b.tar.gz
gentoo-5b8ea5bbb40843dfd21a03a388ccdd94d898516b.tar.bz2
gentoo-5b8ea5bbb40843dfd21a03a388ccdd94d898516b.zip
dev-python/flask-sqlalchemy: fix dependencies, add PyPy3+Py3.8
* Move doc dependencies out of RDEPEND. * Use helpers for doc and tests. 'pytest' without 'die' was useless. * Rely on the default value of DISTUTILS_USE_SETUPTOOLS=bdepend. * Remove useless DISTUTILS_IN_SOURCE_BUILD=1. Bug: https://bugs.gentoo.org/701916 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/flask-sqlalchemy')
-rw-r--r--dev-python/flask-sqlalchemy/flask-sqlalchemy-2.4.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.4.1-r1.ebuild b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..59f37152e7db
--- /dev/null
+++ b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.4.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+MY_PN="Flask-SQLAlchemy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SQLAlchemy support for Flask applications"
+HOMEPAGE="https://pypi.org/project/Flask-SQLAlchemy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/flask-0.10[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues
+
+S="${WORKDIR}/${MY_P}"