summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-testing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-testing')
-rw-r--r--dev-python/flask-testing/Manifest2
-rw-r--r--dev-python/flask-testing/files/0.4.2-test-fix.patch17
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.1.ebuild36
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.2.ebuild37
-rw-r--r--dev-python/flask-testing/metadata.xml8
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/flask-testing/Manifest b/dev-python/flask-testing/Manifest
new file mode 100644
index 000000000000..338d697104f0
--- /dev/null
+++ b/dev-python/flask-testing/Manifest
@@ -0,0 +1,2 @@
+DIST Flask-Testing-0.4.1.tar.gz 39879 SHA256 d8c4d97d79de517a5d6e348bcc6aaccc45832827afa25ca15cdf8a5a16e543a2 SHA512 b7b71a40545aebed2616b5867951078930bc5d2ab6bf4bc259fab4f8d127ace3830f71bdb4a654c96bf5379bce49930c84e77486c8111b0645bfc515428592b0 WHIRLPOOL e3310b41b53da9847ad3143db30359af8a3eb515da42cc4ffc3068d681abb78a8d11302fb26d085197627aae7d7408175819a108dcf25fd2c0270e02ceaef9b7
+DIST Flask-Testing-0.4.2.tar.gz 40994 SHA256 921c7c653e0d511ed87fbf70d984e27afea8dfa7e10b358689863d7a63e05321 SHA512 57f1a58f352637b6c1d4dc5aa8b3cac215eae334f355d40b6c777f9c5a769c745ce11f2a98818669ec2c29fc170fd86fe4670bb66bd4e4607174b21c5c2067e3 WHIRLPOOL a1fc0723660c25cb18ea5eb4c283c79eb379f2d8cee1bf8fda6ed8b10391cdf0080fa3e2e1ce6cdc50845548a5d9be3f4b20ef267c1350a14049adfbdcfa8e20
diff --git a/dev-python/flask-testing/files/0.4.2-test-fix.patch b/dev-python/flask-testing/files/0.4.2-test-fix.patch
new file mode 100644
index 000000000000..a0933e475afc
--- /dev/null
+++ b/dev-python/flask-testing/files/0.4.2-test-fix.patch
@@ -0,0 +1,17 @@
+https://github.com/jarus/flask-testing/commit/c969b41b31f60a5a8bacd44b3eb63d1642f2d8bf
+diff --git a/flask_testing/utils.py b/flask_testing/utils.py
+index add12ef..9b479df 100644
+--- a/flask_testing/utils.py
++++ b/flask_testing/utils.py
+@@ -143,8 +143,8 @@ def _post_teardown(self):
+
+ if _is_signals:
+ template_rendered.disconnect(self._add_template)
+- if hasattr(self, '_true_render'):
+- templating._render = self._true_render
++ if hasattr(self, '_original_template_render'):
++ templating._render = self._original_template_render
+
+ if self.run_gc_after_test:
+ gc.collect()
+
diff --git a/dev-python/flask-testing/flask-testing-0.4.1.ebuild b/dev-python/flask-testing/flask-testing-0.4.1.ebuild
new file mode 100644
index 000000000000..981b65aaca58
--- /dev/null
+++ b/dev-python/flask-testing/flask-testing-0.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Unit testing for Flask"
+HOMEPAGE="http://pythonhosted.org/Flask-Testing/
+ https://pypi.python.org/pypi/Flask-Testing/"
+MY_PN="Flask-Testing"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/twill[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-testing/flask-testing-0.4.2.ebuild b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
new file mode 100644
index 000000000000..c9c8d5279031
--- /dev/null
+++ b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Testing"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unit testing for Flask"
+HOMEPAGE="http://pythonhosted.org/Flask-Testing/ https://pypi.python.org/pypi/Flask-Testing/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/twill[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PV}-test-fix.patch )
+
+python_test() {
+ # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-testing/metadata.xml b/dev-python/flask-testing/metadata.xml
new file mode 100644
index 000000000000..9efb699b494e
--- /dev/null
+++ b/dev-python/flask-testing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-Testing</remote-id>
+ </upstream>
+</pkgmetadata>