summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 23:30:23 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 00:35:15 +0100
commitb56d949615cfc31be8ee270e38208dac342d0150 (patch)
treea89416844ebcf0b6bbedd7bc18aff5b072e6aeaa /dev-python/flask-testing
parentdev-python/flask-socketio: Clean old up (diff)
downloadgentoo-b56d949615cfc31be8ee270e38208dac342d0150.tar.gz
gentoo-b56d949615cfc31be8ee270e38208dac342d0150.tar.bz2
gentoo-b56d949615cfc31be8ee270e38208dac342d0150.zip
dev-python/flask-testing: Clean old up
Diffstat (limited to 'dev-python/flask-testing')
-rw-r--r--dev-python/flask-testing/Manifest1
-rw-r--r--dev-python/flask-testing/flask-testing-0.6.1.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/flask-testing/Manifest b/dev-python/flask-testing/Manifest
index 7aa5a0479ffe..1be39ac997e3 100644
--- a/dev-python/flask-testing/Manifest
+++ b/dev-python/flask-testing/Manifest
@@ -1,3 +1,2 @@
DIST Flask-Testing-0.4.2.tar.gz 40994 BLAKE2B a3d5d5d50598586afde1d4b0f6452919db5c84ed1615ca2b83312f24d04835abd8552bb0d7b3f8c6e03a8664bbd49cf157bc7c2ec935bd6143bfab4584dd4981 SHA512 57f1a58f352637b6c1d4dc5aa8b3cac215eae334f355d40b6c777f9c5a769c745ce11f2a98818669ec2c29fc170fd86fe4670bb66bd4e4607174b21c5c2067e3
-DIST Flask-Testing-0.6.1.tar.gz 42541 BLAKE2B 25eeb05335bf497a360f5df12be57d9776e132ae8cf9f6542d0b192083e9cf940de45cadd845e089f8eb54566ac74a41c4103b4784c35cde7480909c202295e1 SHA512 f7a0a89885693f568e8e03a9ae689add3b9577517faa6b842bb6b990a2be447ecb9ccf693dd5279ca98dfcc8b18e2041fccf0cf36c28cea5fdc0dbdc9b64f065
DIST Flask-Testing-0.6.2.tar.gz 129078 BLAKE2B 099444b21d68a23816edcb7ad55d03080017839ea57334f6a4fc63ab3c3ed9b09ef5989b112fdd41a3180f37a70a3481986068d6e7c8304c1bf8fa01ecd6c277 SHA512 1ce6a32f2c4e2d6d39c0bd2f01b8d20e2ee8faa5cb31d308bbcda2159f8307cc42f445e328a3752c3c3c66f4fffef75b400c70954b1aeb1aabab8a54c565b5ce
diff --git a/dev-python/flask-testing/flask-testing-0.6.1.ebuild b/dev-python/flask-testing/flask-testing-0.6.1.ebuild
deleted file mode 100644
index ef29e92c1d8a..000000000000
--- a/dev-python/flask-testing/flask-testing-0.6.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Testing"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Unit testing for Flask"
-HOMEPAGE="http://pythonhosted.org/Flask-Testing/ https://pypi.python.org/pypi/Flask-Testing/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' 'python2*')"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- local exclude
- if $(python_is_python3); then
- # Twill is not available on python-3
- exclude="-e twill"
- fi
- # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
- nosetests ${exclude} || die "Testing failed with ${EPYTHON}"
-}