summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-28 17:12:31 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-28 17:12:31 +0100
commita85ae0fcf1fe480a01c190518930df85275254bd (patch)
tree32225fd1756171c63be24d1c2a88347bff174716 /dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
parentdev-python/flask-socketio: Remove Py2 (diff)
downloadgentoo-a85ae0fcf1fe480a01c190518930df85275254bd.tar.gz
gentoo-a85ae0fcf1fe480a01c190518930df85275254bd.tar.bz2
gentoo-a85ae0fcf1fe480a01c190518930df85275254bd.zip
dev-python/flask-themes: Remove Py2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild')
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
index c51b0bfa94e9..1da73c8360cb 100644
--- a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
+++ b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1
@@ -17,6 +17,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+# suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
+RESTRICT="test"
RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
@@ -25,10 +27,3 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}"/fixtests.patch )
-
-python_test() {
- # suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
- if ! python_is_python3; then
- PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
- fi
-}