summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-20 20:44:14 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-20 20:46:04 +0200
commit394a4d2b906d70a90886917966bb1f702118c5d9 (patch)
tree68fa6ad2ca6aa85959255c172e7efcb4f07faf20 /dev-python/flask-wtf
parentsys-devel/dev86: Fix make call (#649940), strip properly (#651462) (diff)
downloadgentoo-394a4d2b906d70a90886917966bb1f702118c5d9.tar.gz
gentoo-394a4d2b906d70a90886917966bb1f702118c5d9.tar.bz2
gentoo-394a4d2b906d70a90886917966bb1f702118c5d9.zip
dev-python/flask-wtf: Support Python 3.6, fix dependencies
A lot of the dependencies were missing or not needed. Removing intersphinx from the doc configuration prevents warning during the doc build. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild b/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild
new file mode 100644
index 000000000000..785287cca8fe
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms"
+HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? (
+ ${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ # tries to access things over the network
+ rm tests/test_recaptcha.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests || die "tests failed with ${EPYTHON}"
+}