summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-wtf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/Manifest4
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.2.ebuild52
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.3.ebuild52
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.11.ebuild52
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.12.ebuild52
-rw-r--r--dev-python/flask-wtf/metadata.xml8
6 files changed, 220 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
new file mode 100644
index 000000000000..b0cdc1f4f008
--- /dev/null
+++ b/dev-python/flask-wtf/Manifest
@@ -0,0 +1,4 @@
+DIST Flask-WTF-0.10.2.tar.gz 246659 SHA256 2926a265e6aa163a2102a8f058ad89acb9304665c476cea9687243bcc8f99b45 SHA512 f4736f38a3443903ac6c9f55d448b1f079641721f471d24c1492c54ec1e96b2390c6669325156e8233ecb5c38744f3186ccf47d5df79b6f0c881bd9032836df2 WHIRLPOOL 0890f0004483be6cb5b2fdcbfeb93f83c5c431d40c5fa39c69b31d97941e465149bb4fbbae4be0a0c2ab553b4d398d66179993fc518391ac9205e58dff85a234
+DIST Flask-WTF-0.10.3.tar.gz 247240 SHA256 40da66462df074c2a0fd209e6047972bc226125f6c484c8e367ea10e71ddd718 SHA512 c8cbc817afca7efbc2c0302c4fa3625874159c10e4664b502693acfa3ffcca34aee0a6f17528b45340f1e7f103f87ac72178f2ca4d589307bde12fe47ac5cf50 WHIRLPOOL 08b1b66813a558918ed3e9da8ae2d0db9947f11bf6fccb2ec6f8de1e359422d4431754e982a81a959129230aa39c70470bbad944451238f6c1136976286f303b
+DIST Flask-WTF-0.11.tar.gz 247005 SHA256 2f53a4b314ec26824d0b70f0766b7dd74c6df77bcf8b64de88e1354bc900874b SHA512 213188fd9fb199e4c52cf3e74f5e66846217b817ecf2ffe08ddb5c7cda2ab10a88e3c655364b64393137be1fd105c7d973f82cbd0eca0bfb28bfa3118f5bee15 WHIRLPOOL 559353d70a15e99b18aeb2a54b3c4e27bf5ef0afd870f71085a2dd7384f5b72cfaee9376f45c6280ce19099b3a59152621c8630c9330f5527a03299ae77ec6ce
+DIST Flask-WTF-0.12.tar.gz 247397 SHA256 bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e SHA512 d9861a4fa6ace46fb2a632ff51777bc30af9b63c4f2a35cbe4a68a2777468eb7b6e1813ce331472458c05ce7069f73d998b4e9d3fd9d6ef56fc3abf0bb219a9e WHIRLPOOL 4b044ab1ff2409468f1d1e21a79605432a817322784103cdbfb1708a745cab0f7b8d406607fa5fc594b311daadbcf7e23876fbc2021f2ce9e7d05f8c0852a77b
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.2.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.2.ebuild
new file mode 100644
index 000000000000..8d8e300b0f4b
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.10.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+# silly captcha test trying to access things over the network
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild
new file mode 100644
index 000000000000..a2d55e01bfa6
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.10.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+# silly captcha test trying to access things over the network
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-wtf/flask-wtf-0.11.ebuild b/dev-python/flask-wtf/flask-wtf-0.11.ebuild
new file mode 100644
index 000000000000..94a4bb8cbf49
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+# silly captcha test trying to access things over the network
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-wtf/flask-wtf-0.12.ebuild b/dev-python/flask-wtf/flask-wtf-0.12.ebuild
new file mode 100644
index 000000000000..94a4bb8cbf49
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+# silly captcha test trying to access things over the network
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration"
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-wtf/metadata.xml b/dev-python/flask-wtf/metadata.xml
new file mode 100644
index 000000000000..8ff11cb91124
--- /dev/null
+++ b/dev-python/flask-wtf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-WTF</remote-id>
+ </upstream>
+</pkgmetadata>