summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-23 22:19:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 23:04:55 +0100
commite6ea4894f74a44c235bc0258cdb4015a9301cc33 (patch)
tree87b38b2628f6cf7d832517b8619911129974bdf6 /dev-python/flit
parentdev-python/flit_core: Bump to 3.5.1 (diff)
downloadgentoo-e6ea4894f74a44c235bc0258cdb4015a9301cc33.tar.gz
gentoo-e6ea4894f74a44c235bc0258cdb4015a9301cc33.tar.bz2
gentoo-e6ea4894f74a44c235bc0258cdb4015a9301cc33.zip
dev-python/flit: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/flit-3.5.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index dcd004e1be38..aa13b68fcd5d 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,2 +1,3 @@
DIST flit-3.4.0.tar.gz 120418 BLAKE2B e99eb67daa9a1d8e738ff9b917117edaf7372bbe267163f8af64967e43c3bed94893849e9752d36d3965e70c798dd3fb3b454131cee2d34697cc389f11aaea69 SHA512 18f1d1cb86508e76b4e37e6c1ca2c414400c86e9163bcc52fd3358220e5b4362da4001da7ce427926c62ad67ee86799ea8d08e858e5e17230941c529b9995ce5
DIST flit-3.5.0.tar.gz 122519 BLAKE2B 3c3eee652f090afd1c07e8a5cd1b154e7390ed621ab202ded3b4664d59ccfa2fd827928451f6d8928573d012cb9f6b44544c48540e03b2918d32ae3ba9169838 SHA512 e2239c209f735f11aeec8672aa14449fe4b6e1d2ed6523d661edb730f0b9f93b2794c6676bf878c09bd27966a9f8b9c19e6a7f14063c6efed4d8bc043b4cd2db
+DIST flit-3.5.1.tar.gz 122689 BLAKE2B 49be251df549783114c6758fa688d00fe18ed88d215f91783ce78eda722ee3d8578d83781a1a5c9ee61dd001c82df010c879dc742a1829c2ba8bcf5edb930556 SHA512 00e884774c7f59dfb54d6db09f65ac0ed47f1dd23872d6913f3a41de7242fb3829b2edacd03d08e080635c0a515521333aa74e6d26a2faa5fc02e56454b2b37a
diff --git a/dev-python/flit/flit-3.5.1.ebuild b/dev-python/flit/flit-3.5.1.ebuild
new file mode 100644
index 000000000000..a5cc9637395b
--- /dev/null
+++ b/dev-python/flit/flit-3.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit_core-3.2.0[${PYTHON_USEDEP}]
+ dev-python/intreehooks[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ sys-apps/findutils
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/flit-3.2.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \