summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 21:25:45 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 21:25:45 +0100
commitbd6639ba383164ab4516fc9469172767912f5b47 (patch)
treebc709d727b5b6abe211780fc4950d28aea0ac240 /dev-python/fonttools/fonttools-4.1.0.ebuild
parentwww-misc/vdradmin-am: failed preinst phase fixed (diff)
downloadgentoo-bd6639ba383164ab4516fc9469172767912f5b47.tar.gz
gentoo-bd6639ba383164ab4516fc9469172767912f5b47.tar.bz2
gentoo-bd6639ba383164ab4516fc9469172767912f5b47.zip
dev-python/fonttools: Add fix for dev-python/pytest-shutil fallout
* When dev-python/pytest-shutil is installed, pytest fails importing all tests. Closes: https://bugs.gentoo.org/701148 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/fonttools/fonttools-4.1.0.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-4.1.0.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-4.1.0.ebuild b/dev-python/fonttools/fonttools-4.1.0.ebuild
index 3e2e55324904..7501d28d43e7 100644
--- a/dev-python/fonttools/fonttools-4.1.0.ebuild
+++ b/dev-python/fonttools/fonttools-4.1.0.ebuild
@@ -29,6 +29,22 @@ DEPEND="${RDEPEND}
app-arch/zopfli
)"
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
# virtualx used when matplotlib is installed causing plot module tests to run
virtx pytest -vv Tests fontTools || die "pytest failed"