summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 17:21:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 18:18:50 +0100
commit7cd5301896b2f31beea3be1408d340f33b5cf1a1 (patch)
treea7e6bcba0ca6d350b04cc9cdfefe34712a47c071 /dev-python/fonttools
parentdev-python/testfixtures: Bump to 6.17.0 (diff)
downloadgentoo-7cd5301896b2f31beea3be1408d340f33b5cf1a1.tar.gz
gentoo-7cd5301896b2f31beea3be1408d340f33b5cf1a1.tar.bz2
gentoo-7cd5301896b2f31beea3be1408d340f33b5cf1a1.zip
dev-python/fonttools: Bump to 4.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.18.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 6b829947816e..406c663416d6 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.1.0.tar.gz 2253792 BLAKE2B 470207d74404851aa111142ad8541d45820ded0212029867c289f2e7741d4b41b4ac824f65555a23d4f3dcc974428537cd319a8787bc4d80f2fb67561a21d1ee SHA512 3d9485cd34b5ea3dfdcc26474e0b21a96811b84eda16341c39165aea72bb09c3cf3360a069b316ae6575a399e26f6518c199180caec7bb959f245ced7ca45e3b
DIST fonttools-4.18.1.tar.gz 2498166 BLAKE2B 9ea9fd372c71883e37756c9b0b5bcd193782d49a99df37e7245f788362b284af8e5b9456c31b1c6b84fb6cccd8bce0339e95c87cecc008f0130e47a40c74bfe5 SHA512 d87c466e87ffa70bb15ee40f889b25e1187d51a1074b6e47a259d5984d51d7ce988ef50db91796fcbd06b5692b2c627d0a4cd76e3be6d0da348c0872ff01317c
+DIST fonttools-4.18.2.tar.gz 2499129 BLAKE2B 1ae93418121942e4303e4b138b192a30195d25c87e8c6204b508cc6a5b7a87608fcde7acbb6a2e8fb3c71ea59938827dabbe1556b7edad537523f6f0b3615696 SHA512 ceec3656c674ff5c43f4dc7cdf1468ddaf5c8bbe569d865fb015a9251ac089caedcf3dcea82c93a0c367576fcd7d65451642a6ab5d3093d941aa391b50070d53
diff --git a/dev-python/fonttools/fonttools-4.18.2.ebuild b/dev-python/fonttools/fonttools-4.18.2.ebuild
new file mode 100644
index 000000000000..c1277db3ff69
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.18.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx pytest -vv Tests fontTools
+}