summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-09 18:01:41 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-09 18:02:00 +0100
commite0db0993f24b96e55def63a8e558904bb24057f0 (patch)
tree3d94df2d933a0d797f2511a6b881ba34e8e18a00 /dev-python/fonttools
parentnet-im/zoom: Remove old. (diff)
downloadgentoo-e0db0993f24b96e55def63a8e558904bb24057f0.tar.gz
gentoo-e0db0993f24b96e55def63a8e558904bb24057f0.tar.bz2
gentoo-e0db0993f24b96e55def63a8e558904bb24057f0.zip
dev-python/fonttools: Bump to 4.18.1
Closes: https://bugs.gentoo.org/746854 Closes: https://bugs.gentoo.org/718678 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.18.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 048584b5158f..6b829947816e 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1 +1,2 @@
DIST fonttools-4.1.0.tar.gz 2253792 BLAKE2B 470207d74404851aa111142ad8541d45820ded0212029867c289f2e7741d4b41b4ac824f65555a23d4f3dcc974428537cd319a8787bc4d80f2fb67561a21d1ee SHA512 3d9485cd34b5ea3dfdcc26474e0b21a96811b84eda16341c39165aea72bb09c3cf3360a069b316ae6575a399e26f6518c199180caec7bb959f245ced7ca45e3b
+DIST fonttools-4.18.1.tar.gz 2498166 BLAKE2B 9ea9fd372c71883e37756c9b0b5bcd193782d49a99df37e7245f788362b284af8e5b9456c31b1c6b84fb6cccd8bce0339e95c87cecc008f0130e47a40c74bfe5 SHA512 d87c466e87ffa70bb15ee40f889b25e1187d51a1074b6e47a259d5984d51d7ce988ef50db91796fcbd06b5692b2c627d0a4cd76e3be6d0da348c0872ff01317c
diff --git a/dev-python/fonttools/fonttools-4.18.1.ebuild b/dev-python/fonttools/fonttools-4.18.1.ebuild
new file mode 100644
index 000000000000..c1277db3ff69
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.18.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx pytest -vv Tests fontTools
+}