summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-01 12:54:26 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-01 15:37:16 -0700
commitd28db303a26db8d36229ae68b64df30b6b18c485 (patch)
tree438a64defbd729290d2ae099f5e8017d7a786ab0 /dev-python/fqdn/fqdn-1.1.1.ebuild
parentsci-mathematics/isabelle: fix scala dependency. (diff)
downloadgentoo-d28db303a26db8d36229ae68b64df30b6b18c485.tar.gz
gentoo-d28db303a26db8d36229ae68b64df30b6b18c485.tar.bz2
gentoo-d28db303a26db8d36229ae68b64df30b6b18c485.zip
dev-python/fqdn: new package
RFC-compliant FQDN validation and manipulation for Python Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/fqdn/fqdn-1.1.1.ebuild')
-rw-r--r--dev-python/fqdn/fqdn-1.1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fqdn/fqdn-1.1.1.ebuild b/dev-python/fqdn/fqdn-1.1.1.ebuild
new file mode 100644
index 000000000000..a9a2b0dd0060
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/guyhughes/fqdn"
+SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/cached-property[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}