summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/frozen-flask
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/frozen-flask')
-rw-r--r--dev-python/frozen-flask/Manifest1
-rw-r--r--dev-python/frozen-flask/frozen-flask-0.11-r1.ebuild44
-rw-r--r--dev-python/frozen-flask/metadata.xml9
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/frozen-flask/Manifest b/dev-python/frozen-flask/Manifest
new file mode 100644
index 000000000000..de665f77b1f9
--- /dev/null
+++ b/dev-python/frozen-flask/Manifest
@@ -0,0 +1 @@
+DIST Frozen-Flask-0.11.tar.gz 106927 SHA256 c348e0165b161efa44770157eba3e006cc6a1e9867bfd74670cbc56529cc5512 SHA512 a734c6e090f08b01756b677a577c013e0198272a9e469410be81e5214eceb34d98e163410e8e04850036c58c5e7c9e718145e69cd26dd9e30c821f6949aede76 WHIRLPOOL 60a54174665e96b4f3921b72bb1f5f313f53c983d84e3dc6fd917f7273ace98a364638d925776eb5cfa6b709d8ee7c935cd3b9bbbb8926550513e3a54e517d59
diff --git a/dev-python/frozen-flask/frozen-flask-0.11-r1.ebuild b/dev-python/frozen-flask/frozen-flask-0.11-r1.ebuild
new file mode 100644
index 000000000000..acf049c3e6b6
--- /dev/null
+++ b/dev-python/frozen-flask/frozen-flask-0.11-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Frozen-Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Freezes a Flask application into a set of static files"
+HOMEPAGE="https://github.com/SimonSapin/Frozen-Flask http://pypi.python.org/pypi/Frozen-Flask"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sed -e 's:^intersphinx_mapping:#intersphinx_mapping:' -i docs/conf.py || die
+ mkdir docs/_build || die
+ sphinx-build -c docs docs docs/_build || die
+ fi
+}
+
+python_test() {
+ nosetests || die Tests failed under $"{EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/frozen-flask/metadata.xml b/dev-python/frozen-flask/metadata.xml
new file mode 100644
index 000000000000..f0f9f1aa3906
--- /dev/null
+++ b/dev-python/frozen-flask/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Frozen-Flask</remote-id>
+ <remote-id type="github">SimonSapin/Frozen-Flask</remote-id>
+ </upstream>
+</pkgmetadata>