summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-24 14:18:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-24 14:42:24 +0100
commitdaa3a60c24e4c1df13c2aee1d9afcd72e261d8dc (patch)
tree33851a6e6437a40367f7298578365a7a523ee669 /dev-python/frozendict
parentdev-python/qiskit-aer: Bump to 0.13.1 (diff)
downloadgentoo-daa3a60c24e4c1df13c2aee1d9afcd72e261d8dc.tar.gz
gentoo-daa3a60c24e4c1df13c2aee1d9afcd72e261d8dc.tar.bz2
gentoo-daa3a60c24e4c1df13c2aee1d9afcd72e261d8dc.zip
dev-python/frozendict: Bump to 2.3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/frozendict-2.3.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index 408059af09b7..d63e2694f4bf 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1 +1,2 @@
DIST frozendict-2.3.8.gh.tar.gz 310193 BLAKE2B e21d278396bcc10d88dbc6d33c86027308f66c8de84015d1aa186f1f34e74e4be7c915459a694597e277aab0eaaa78fb716e51e5c0f9fba58bb1e8b8d22394bd SHA512 17f610fc12138446908dbd425b8b15d2b6b7d8ad2b41f68b9a03acbd096d173994049b86169c62b51732cacf1e19de77e58cd38edf3422413269bd9e4eb5ca6d
+DIST frozendict-2.3.9.gh.tar.gz 310538 BLAKE2B 9095cc85fc25ddab23a30879a623b4e09557d7c8d27f51199913002d8dffe58e965174360e964a7f87c556d0b282c2fe6718bf01dc4483bb642db431e53dd0ce SHA512 e724c316c9c4f9c11127bd70ac9dd8e9f9012c61797ca55593b405109d09277657c1c3177183051b6f7d8f7ac86e70715a3448136c2c196db5393271a2fd4fb7
diff --git a/dev-python/frozendict/frozendict-2.3.9.ebuild b/dev-python/frozendict/frozendict-2.3.9.ebuild
new file mode 100644
index 000000000000..4b760aa0a439
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # upstream provides a C extensions for python3.10 only, and errors out
+ # if we enable it for newer versions, so the extra effort does not seem
+ # to be worth it
+ local -x FROZENDICT_PURE_PY=1
+ distutils-r1_python_compile
+}