summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-15 22:27:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-15 23:07:30 +0200
commita900f018124cf5aae03df272f87a7d28ea151b69 (patch)
tree78844db06f0959c6473bef6bf282b6e433421414 /dev-python/fsspec
parentapp-admin/awscli: Bump to 1.20.63 (diff)
downloadgentoo-a900f018124cf5aae03df272f87a7d28ea151b69.tar.gz
gentoo-a900f018124cf5aae03df272f87a7d28ea151b69.tar.bz2
gentoo-a900f018124cf5aae03df272f87a7d28ea151b69.zip
dev-python/fsspec: Bump to 2021.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2021.10.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 1f002df7090a..f8e36709fde1 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,4 @@
DIST filesystem_spec-2021.08.1.tar.gz 303969 BLAKE2B bc67e980cb7d5def227feec16d984630703e817fb696fafd53db7c56634e8e101ac8a68ad6d3ea3b0cbed475f431b5847e3e0612cd1f5abc2bd753ef4f6004e0 SHA512 7757480ff8f113715bdf4be400af9b9c5a3f8b52abc8cc8ccc608f2fea0f3c77f074db1aa5e7ce5d0462ae86a702af8058f8a8935b99617e6803bc7344801b8e
DIST filesystem_spec-2021.09.0.tar.gz 311338 BLAKE2B e448c0e8a0f24f2374bf6b701bb72b10c91b0058b81947fb538ad96412170e6b71ae5e49fb0f679f0a7031f1206f706bbf4f90ecc118d89da621c5cb4f8f4875 SHA512 65ee4f7f7d1dd235dcb6dc6933bb2eb62c91cb50d08703becb0b84640c40efed09cf326478c84316f4edb3cd08650ff1d93e222083463c868e8ca2b8a9fb5f91
DIST filesystem_spec-2021.10.0.tar.gz 313863 BLAKE2B eaffcbf4b7ef1821406664062961f36e8490ffc36e6b64dbd3be820785c41742f741a8f0e76db5ee0a75e2dfc609000a572ebf5c02dc9118b2a45413a498de32 SHA512 2b478a88c0aa84fb55f8946923f79900350e36395bc6110181966404e6fb6d5fbdb3b6ea19e2e7077c8167f65266a68ac962af25dfb1cfe573f5e74c34329fe8
+DIST filesystem_spec-2021.10.1.tar.gz 315068 BLAKE2B c9be13ba8a2821274335fb924e91904640f4505a7e639211c7b6701f63f7dcddae018c15933b291d4f4d9f2ea451136e09ede637d615985889b565a12ac93665 SHA512 2f89a24b5491e15d3b3d9a2e6307c6d4a0db61848ad5e9324f4e234d4204e3a1f78b00a50b26f6fe90d657df6700aa23cb76f5df996b29dd880b7c8677d21382
diff --git a/dev-python/fsspec/fsspec-2021.10.1.ebuild b/dev-python/fsspec/fsspec-2021.10.1.ebuild
new file mode 100644
index 000000000000..2f83ce072601
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)