summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 08:25:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-02 09:50:32 +0200
commite39b5d98c45431653ef872e7906d014d841a2462 (patch)
tree6dc456941b7fef2416490f5b5eafebff873b95d5 /dev-python/fsspec
parentdev-python/pytz: Bump to 2021.3 (diff)
downloadgentoo-e39b5d98c45431653ef872e7906d014d841a2462.tar.gz
gentoo-e39b5d98c45431653ef872e7906d014d841a2462.tar.bz2
gentoo-e39b5d98c45431653ef872e7906d014d841a2462.zip
dev-python/fsspec: Bump to 2021.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2021.10.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 9c3c0ad5480b..926c0bd82229 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,4 @@
DIST filesystem_spec-2021.07.0.tar.gz 301517 BLAKE2B 84b189e636eaeb4d3724e1afc44795e83b3ac576ab8640b4fee916bb7cf341c5cd6b1b475616225927693d13f204a1750f913f2e6d35b541fb8ff26ee1019400 SHA512 bea483734e6c9773d93ee93b526c8074a28f0671fbee17b39858dc7a75fd71553ca6d8d5c4e2204446bca3e7c23f6d4c8e94b62ff920e546a2b71786d0dcb388
DIST filesystem_spec-2021.08.1.tar.gz 303969 BLAKE2B bc67e980cb7d5def227feec16d984630703e817fb696fafd53db7c56634e8e101ac8a68ad6d3ea3b0cbed475f431b5847e3e0612cd1f5abc2bd753ef4f6004e0 SHA512 7757480ff8f113715bdf4be400af9b9c5a3f8b52abc8cc8ccc608f2fea0f3c77f074db1aa5e7ce5d0462ae86a702af8058f8a8935b99617e6803bc7344801b8e
DIST filesystem_spec-2021.09.0.tar.gz 311338 BLAKE2B e448c0e8a0f24f2374bf6b701bb72b10c91b0058b81947fb538ad96412170e6b71ae5e49fb0f679f0a7031f1206f706bbf4f90ecc118d89da621c5cb4f8f4875 SHA512 65ee4f7f7d1dd235dcb6dc6933bb2eb62c91cb50d08703becb0b84640c40efed09cf326478c84316f4edb3cd08650ff1d93e222083463c868e8ca2b8a9fb5f91
+DIST filesystem_spec-2021.10.0.tar.gz 313863 BLAKE2B eaffcbf4b7ef1821406664062961f36e8490ffc36e6b64dbd3be820785c41742f741a8f0e76db5ee0a75e2dfc609000a572ebf5c02dc9118b2a45413a498de32 SHA512 2b478a88c0aa84fb55f8946923f79900350e36395bc6110181966404e6fb6d5fbdb3b6ea19e2e7077c8167f65266a68ac962af25dfb1cfe573f5e74c34329fe8
diff --git a/dev-python/fsspec/fsspec-2021.10.0.ebuild b/dev-python/fsspec/fsspec-2021.10.0.ebuild
new file mode 100644
index 000000000000..2f83ce072601
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)