summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-10-16 23:24:06 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-18 22:02:22 +0200
commitfd9a5a0a3c15d7400b936ce0f0814fd4078e900c (patch)
tree85e45c61f492ae49bfed6b6277462a124bc2e8e0 /dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
parentdev-python/funcsigs: revision bump 1.0.2-r1 (diff)
downloadgentoo-fd9a5a0a3c15d7400b936ce0f0814fd4078e900c.tar.gz
gentoo-fd9a5a0a3c15d7400b936ce0f0814fd4078e900c.tar.bz2
gentoo-fd9a5a0a3c15d7400b936ce0f0814fd4078e900c.zip
dev-python/funcsigs: fix test issue with pypy3
This commit disables 2 tests because they fail to run with pypy3. This has been reported upstream. Upstream bug: https://github.com/testing-cabal/funcsigs/issues/10 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564852 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2571 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild')
-rw-r--r--dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild b/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
index 01f0536d3ea1..ea3b7a6b6f98 100644
--- a/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
+++ b/dev-python/funcsigs/funcsigs-1.0.2-r1.ebuild
@@ -22,6 +22,13 @@ DEPEND="
test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
RDEPEND=""
+PATCHES=(
+ # This patch disables some tests for pypy as they do not work as expected.
+ # This has been reported upstream
+ # https://github.com/testing-cabal/funcsigs/issues/10
+ "${FILESDIR}/${P}-fix-pypy3-tests.patch"
+)
+
python_test() {
esetup.py test
}