summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 13:22:06 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 13:27:41 -0700
commitf07c5748c9c8b8e1e926e7b6029725ef4fbb74ef (patch)
tree919cbbe08a9eadd73b22c0eb3e7e188631e5ca8e /dev-python/fusepy/fusepy-3.0.1.ebuild
parentmedia-gfx/gphotofs: bump to EAPI 7 and add sys-fs/fuse slot dep (diff)
downloadgentoo-f07c5748c9c8b8e1e926e7b6029725ef4fbb74ef.tar.gz
gentoo-f07c5748c9c8b8e1e926e7b6029725ef4fbb74ef.tar.bz2
gentoo-f07c5748c9c8b8e1e926e7b6029725ef4fbb74ef.zip
dev-python/fusepy: version bump to 3.0.1
Closes: https://bugs.gentoo.org/684924 Closes: https://bugs.gentoo.org/697016 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/fusepy/fusepy-3.0.1.ebuild')
-rw-r--r--dev-python/fusepy/fusepy-3.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/fusepy/fusepy-3.0.1.ebuild b/dev-python/fusepy/fusepy-3.0.1.ebuild
new file mode 100644
index 000000000000..dff543e781d4
--- /dev/null
+++ b/dev-python/fusepy/fusepy-3.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings using ctypes"
+HOMEPAGE="https://github.com/fusepy/fusepy https://pypi.org/project/fusepy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=sys-fs/fuse-2.9.7:0
+ !dev-python/fuse-python
+"