summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-09-25 19:24:09 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-09-25 19:24:09 +0800
commitfad680fce4f0cb9d084400dd432f71583189a1c0 (patch)
treee2f6eb81ed12d8379c1e83320b1fd8d1f207c79a /dev-python/gast/gast-0.3.3-r1.ebuild
parentapp-shells/powerline: tested on Python 3.8. (diff)
downloadgentoo-fad680fce4f0cb9d084400dd432f71583189a1c0.tar.gz
gentoo-fad680fce4f0cb9d084400dd432f71583189a1c0.tar.bz2
gentoo-fad680fce4f0cb9d084400dd432f71583189a1c0.zip
dev-python/gast: tested on Python 3.8.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/gast/gast-0.3.3-r1.ebuild')
-rw-r--r--dev-python/gast/gast-0.3.3-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.3.3-r1.ebuild b/dev-python/gast/gast-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..a2d5b861bc85
--- /dev/null
+++ b/dev-python/gast/gast-0.3.3-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"