summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-04-20 21:26:21 -0700
committerZac Medico <zmedico@gentoo.org>2016-04-20 21:27:01 -0700
commit126642811ace579236768674c0801f920122c2bf (patch)
treebf8fc70400444b3da474e70aeda98e9526122dd0 /dev-python/gcs-oauth2-boto-plugin
parentdev-libs/leatherman: bup (diff)
downloadgentoo-126642811ace579236768674c0801f920122c2bf.tar.gz
gentoo-126642811ace579236768674c0801f920122c2bf.tar.bz2
gentoo-126642811ace579236768674c0801f920122c2bf.zip
dev-python/gcs-oauth2-boto-plugin: fix SocksiPy-branch reference for bug 577892
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild7
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild7
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.9.ebuild7
3 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild
index 5793adac44bc..c4af2e6025e9 100644
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild
@@ -32,3 +32,10 @@ RDEPEND="${PYTHON_DEPS}
>=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
>=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
>=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed \
+ -e '/SocksiPy-branch/d' \
+ -i setup.py || die
+}
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild
index 14c963466d24..293b176c8a48 100644
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild
@@ -30,3 +30,10 @@ RDEPEND="${PYTHON_DEPS}
>=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
>=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
>=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed \
+ -e '/SocksiPy-branch/d' \
+ -i setup.py || die
+}
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.9.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.9.ebuild
index 6c00d4dc6c36..2b8dcabe6741 100644
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.9.ebuild
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.9.ebuild
@@ -30,3 +30,10 @@ RDEPEND="${PYTHON_DEPS}
>=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
>=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
>=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed \
+ -e '/SocksiPy-branch/d' \
+ -i setup.py || die
+}