summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 20:02:36 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 20:02:36 +0100
commit92293ddd101e25b5fc438b613d16d4a6b571e452 (patch)
tree7fe65f3f0d87e744875b21fc3f4f1e3695b4c590 /dev-python/geopy/geopy-1.11.0.ebuild
parentdev-python/foolscap: Bump (diff)
downloadgentoo-92293ddd101e25b5fc438b613d16d4a6b571e452.tar.gz
gentoo-92293ddd101e25b5fc438b613d16d4a6b571e452.tar.bz2
gentoo-92293ddd101e25b5fc438b613d16d4a6b571e452.zip
dev-python/geopy: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/geopy/geopy-1.11.0.ebuild')
-rw-r--r--dev-python/geopy/geopy-1.11.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/geopy/geopy-1.11.0.ebuild b/dev-python/geopy/geopy-1.11.0.ebuild
new file mode 100644
index 000000000000..52550f3460f5
--- /dev/null
+++ b/dev-python/geopy/geopy-1.11.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Geocoding Toolbox for Python"
+HOMEPAGE="http://www.geopy.org/ https://github.com/geopy/geopy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="test doc timezone yahoo"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="yahoo? ( >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+ dev-python/placefinder[${PYTHON_USEDEP}] )
+ timezone? ( dev-python/pytz[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/python-docs-2.7.6-r1:2.7 )"
+
+REQUIRED_USE="test? ( yahoo timezone )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+
+ # prevent install of test folder to avoid file collisions
+ sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
+}
+
+python_test() {
+ # broken tests
+ rm test/geocoders/openmapquest.py
+ sed -i -e 's/from .openmapquest import OpenMapQuestTestCase//' test/geocoders/__init__.py
+ # Ignore rogue class IGNFranceTestCase demanding elements beyond a normal testsuite
+ # i.e. "You should provide an api key and a username with a password"
+ # Cannot decipher how to skip or exclude this "context=IGNFranceTestCase"
+ # It appears it MAY stem from nose rather than geopy's suite
+ nosetests --verbose || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}