summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Hesling <hesling@chromium.org>2020-01-26 10:38:25 +0000
committerSebastian Pipping <sping@gentoo.org>2020-01-26 23:42:49 +0100
commit48ddca6fa973721e4647ac464fc5def7bddfe748 (patch)
treecd86010278d44f661d4ee93d3aff4f1b8eb935e6 /dev-python/gevent
parentsys-auth/keystone: cleanup (diff)
downloadgentoo-48ddca6fa973721e4647ac464fc5def7bddfe748.tar.gz
gentoo-48ddca6fa973721e4647ac464fc5def7bddfe748.tar.bz2
gentoo-48ddca6fa973721e4647ac464fc5def7bddfe748.zip
dev-python/gevent: bump to 1.4.0
Closes: https://github.com/gentoo/gentoo/pull/14458 Signed-off-by: Craig Hesling <hesling@chromium.org> Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest1
-rw-r--r--dev-python/gevent/gevent-1.4.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index 86bf972ee6c3..cf6c378e2fcb 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -3,3 +3,4 @@ DIST gevent-1.2.1.tar.gz 2808619 BLAKE2B 2e3c15adb33401012951f0f93fe7f17c1c7597b
DIST gevent-1.2.2.tar.gz 3108671 BLAKE2B f80df00f58ae2f65aa7f65fc9eac5cbf63a0084f24ccebc71ba9bafba72cd48fff2e7d0b1d8de7939dc669d7708e120fc14077cc845fe3ce212d6a80a42b5158 SHA512 1e2dd544cffea62ee32de2e4066b3f4c121058a1211b89da281ec3882f3763217fe2d346ce38b66e27df9f59cfe05bb137d1608a681dd10eaf06a33dc22f531c
DIST gevent-1.3.5.tar.gz 4609085 BLAKE2B 55cb4111c9eaf9bbf636c9f1ef8d695def15a92e5591a0c441aae27f41a126487b37b8cc7a701a43453109f24114e3a0c584dff4b9b202018fd8334f0bae8e8d SHA512 4fd6d66e62437c859d653de4e981500fb3a025e6608b91fbb3d5ba4d8f0bff7cce980c03484c1c160a608427979ca763a6660d40ffcb45df4abe5f152ce65d1c
DIST gevent-1.3.7.tar.gz 4614437 BLAKE2B 43d50c36fba2bedf41a7b33d38180f096b18846146953fa68325155f4a3cb6edb7352b9bb4cff5c7eca7a06ac25dc5b3e82a04545704fd0d6f43e9839a8749a1 SHA512 6dba487a9527eb352dc6a5f57120bf7973da655b3a331cad6637271b626c6e9e5439b20ee8abd9035ecb36e5259c99c69dea5ecdb8fa7ad0dbe28876c4d746d8
+DIST gevent-1.4.0.tar.gz 5169595 BLAKE2B 0c78f67bc94d15419b8eadf8825d9657c6a7a82756308216e1ca94d5465c25836cb736b8b370a12d1003eb8614effd4110d8ed47ee2b0d7febc2bda4038adc0a SHA512 6771f4f2932055270e4f5a79ae815e93fd0f471defa7f437dc84907ea8b44672e05ae5eb6958f8d90580b2471785dce4044d9d1bbea0dd0c34c1381d88af0344
diff --git a/dev-python/gevent/gevent-1.4.0.ebuild b/dev-python/gevent/gevent-1.4.0.ebuild
new file mode 100644
index 000000000000..4e9650bf6fcf
--- /dev/null
+++ b/dev-python/gevent/gevent-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-libs/libev-4.23
+ >=net-dns/c-ares-1.12
+ >=dev-python/greenlet-0.4.14
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd src/greentest || die
+
+ GEVENT_RESOLVER=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py || die
+ GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
+ "${PYTHON}" testrunner.py --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}