summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-26 15:01:18 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-26 15:26:53 +0100
commitc30de31026df52c5a6964ace353de98c99d5db23 (patch)
tree35480e6574eb587dfe993f23fb199cc6c6df391f /dev-python/gevent
parentdev-python/python-gflags: Port to python 3.9 (diff)
downloadgentoo-c30de31026df52c5a6964ace353de98c99d5db23.tar.gz
gentoo-c30de31026df52c5a6964ace353de98c99d5db23.tar.bz2
gentoo-c30de31026df52c5a6964ace353de98c99d5db23.zip
dev-python/gevent: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest3
-rw-r--r--dev-python/gevent/gevent-20.12.0.ebuild86
-rw-r--r--dev-python/gevent/gevent-20.12.1.ebuild86
-rw-r--r--dev-python/gevent/gevent-20.9.0.ebuild86
4 files changed, 0 insertions, 261 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index a9697a5e7faf..cbc3cd64ece7 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -1,4 +1 @@
-DIST gevent-20.12.0.tar.gz 5898634 BLAKE2B a73129c7d393aedcd84b6e62c890c3b306722876a1ea4c96485096ce2ea7d1db5f03c77ea77a2c35ef41c7a96183246316c577735bcf4b25fb41095282c64d38 SHA512 76c75128ba2b33e47bd85ef2788387aa6d47d230ef9aeac4bceee03e8a2555dd204c321de7d1779fe4f44503e4fca5dce3b43c1922238da994faed0d78e5c4c1
-DIST gevent-20.12.1.tar.gz 5908977 BLAKE2B fd3536de1ca518e889868537cfb856d022ec2be8f5f658cddb06b9797841333a475d2c4d7eb3f97ecd715a19999804e724f8126b189087582452a88076bf5d12 SHA512 63bf8d63ed0eeed63b5ae6b58a2a0a36bb4a606d7d76f51cb59d5b76aa639296264a01455699cfb6abee53c958368c17f4c6bfca1543d04f9d750637b113046b
-DIST gevent-20.9.0.tar.gz 5806581 BLAKE2B 6b1b653fa6e22539e049a9bba3d3a2b9d798a5555ce4ba60ce33ecbdf14bb5201967d22d677e1ce3170129b0763fddfcc5991347186fb102d10ae39e22538c44 SHA512 966efc945b623df2521fffadca3b7e56cae1efe6de904a724765e0593389e8b1305094baa6fbc9f4fa376b1157d0f230b01e2a90de21e4b9650614363edec9f4
DIST gevent-21.1.2.tar.gz 5943652 BLAKE2B ef85e9941a8e46370437a34728c012f9d8976b5680b22bf9b13ab35d7417019ac0e85fac5cfc8632972e38a2f70028a00ba3fe9f8be11aa2ff64e364052da594 SHA512 1ee2b748a97fa40f67ad2c3b83c6b9f48dbfaae9f2b4f1c118919cfd642c1ca27de0e33a00d950f003f90131354b56a4868ce3051864dbe2ea9b7f22eeafc1eb
diff --git a/dev-python/gevent/gevent-20.12.0.ebuild b/dev-python/gevent/gevent-20.12.0.ebuild
deleted file mode 100644
index abdfa4f3151b..000000000000
--- a/dev-python/gevent/gevent-20.12.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~mips ~ppc ppc64 s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libev-4.31:=
- dev-libs/libuv:=
- >=net-dns/c-ares-1.12:=
- >=dev-python/greenlet-0.4.17
- dev-python/zope-event[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-#RESTRICT="test"
-
-python_prepare_all() {
- export LIBEV_EMBED="false"
- export CARES_EMBED="false"
- export EMBED="false"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_test() {
- cd src/gevent/tests || die
- # TODO: figure out how to make them work and not hang
-# GEVENT_RESOLVER=ares \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=dnspython \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=thread \
-# "${EPYTHON}" -m gevent.tests \
-# --verbose \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
- GEVENT_FILE=thread \
- "${EPYTHON}" -m gevent.tests \
- --verbose \
- -uall,-network \
- --config known_failures.py \
- test__*subprocess*.py || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/gevent/gevent-20.12.1.ebuild b/dev-python/gevent/gevent-20.12.1.ebuild
deleted file mode 100644
index 43a7f0126faa..000000000000
--- a/dev-python/gevent/gevent-20.12.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libev-4.31:=
- dev-libs/libuv:=
- >=net-dns/c-ares-1.12:=
- >=dev-python/greenlet-0.4.17
- dev-python/zope-event[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-#RESTRICT="test"
-
-python_prepare_all() {
- export LIBEV_EMBED="false"
- export CARES_EMBED="false"
- export EMBED="false"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_test() {
- cd src/gevent/tests || die
- # TODO: figure out how to make them work and not hang
-# GEVENT_RESOLVER=ares \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=dnspython \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=thread \
-# "${EPYTHON}" -m gevent.tests \
-# --verbose \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
- GEVENT_FILE=thread \
- "${EPYTHON}" -m gevent.tests \
- --verbose \
- -uall,-network \
- --config known_failures.py \
- test__*subprocess*.py || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/gevent/gevent-20.9.0.ebuild b/dev-python/gevent/gevent-20.9.0.ebuild
deleted file mode 100644
index 61a02d602511..000000000000
--- a/dev-python/gevent/gevent-20.9.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~mips ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libev-4.31:=
- dev-libs/libuv:=
- >=net-dns/c-ares-1.12:=
- >=dev-python/greenlet-0.4.17
- dev-python/zope-event[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-#RESTRICT="test"
-
-python_prepare_all() {
- export LIBEV_EMBED="false"
- export CARES_EMBED="false"
- export EMBED="false"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_test() {
- cd src/gevent/tests || die
- # TODO: figure out how to make them work and not hang
-# GEVENT_RESOLVER=ares \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=dnspython \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=thread \
-# "${EPYTHON}" -m gevent.tests \
-# --verbose \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
- GEVENT_FILE=thread \
- "${EPYTHON}" -m gevent.tests \
- --verbose \
- -uall,-network \
- --config known_failures.py \
- test__*subprocess*.py || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}