summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-07-03 22:17:03 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-07-03 22:39:40 +0200
commit2e2e48536c04da801f23190951939905ad77d2b7 (patch)
tree980d09c988716adf44ff194d6cdb5f9dc727e9ef /dev-python/geventhttpclient
parentsys-apps/opal-utils: bump to 6.6.2 (diff)
downloadgentoo-2e2e48536c04da801f23190951939905ad77d2b7.tar.gz
gentoo-2e2e48536c04da801f23190951939905ad77d2b7.tar.bz2
gentoo-2e2e48536c04da801f23190951939905ad77d2b7.zip
dev-python/geventhttpclient: bump to 1.4.3, add Python 3.9 support
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 6f2baae226d8..64e53ed868e3 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,2 +1,3 @@
DIST geventhttpclient-1.3.1.tar.gz 82598 BLAKE2B 5fef20a74c431ed53be4eedb3ec7e040572ad960363d41dda8b93c8f08f3eb05ba6160676c1c3ed957d1528a12aa297400063377f3788754e9e76401bb3421ae SHA512 a50486e1485c449a821176f0aa139cb05a3c7675fb045086e086cc7bb71d6e1d75191fae6972b381e7e69dba89d23c387464503845badd29fa361e03aa866079
DIST geventhttpclient-1.4.2.tar.gz 57535 BLAKE2B f3c17140698b1609d9953110790fb536d982782c60165c717b6cee290c0b8fa5ae99cd6935401b6b617f0bd021783dd3f836c7cff775f513b9084714da1575a7 SHA512 3252d27f07a4642ba34d449664f50451b2ca4e44dc508345133d21acf659251a66be72784bacd312c074de4025dd5e080bdf35c84d9f7d40057132184a4d285d
+DIST geventhttpclient-1.4.3.tar.gz 57541 BLAKE2B 6b28cba862eb01bb1a298c2e228eac4f4bfbf91cd138d0e77f54a91184672f089d3233b7287940b3892fd7e732c924612044abba0704054112f8c0563d9ed741 SHA512 1360a95d367b3bbf03294be916f70f8c2e655b77180a7ff44e67a40508584500e4a0017416639c0a90a974fe53cc7895dc9c3f7bf43d3a34fc4484f804793c21
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
new file mode 100644
index 000000000000..4d3f4094b52b
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.4.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Skip SNI tests which require dpkt
+ sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ # Require dpkt
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ # Append to sys.path to avoid ImportError
+ # https://bugs.gentoo.org/667758
+ # Skip tests which require internet access
+ pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
+ -m "not online" || die "Tests failed with ${EPYTHON}"
+}