summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-09-02 22:57:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-09-02 22:57:07 -0500
commitc96d66c97ad5e9a3ef4b77515d32947fe01c6b8c (patch)
tree1387a4baf629d8abf189598377e581972b4c87ba /dev-python/git-review/git-review-1.25.0.ebuild
parentdev-python/python-saharaclient: bup for liberty (diff)
downloadgentoo-c96d66c97ad5e9a3ef4b77515d32947fe01c6b8c.tar.gz
gentoo-c96d66c97ad5e9a3ef4b77515d32947fe01c6b8c.tar.bz2
gentoo-c96d66c97ad5e9a3ef4b77515d32947fe01c6b8c.zip
dev-python/git-review: bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/git-review/git-review-1.25.0.ebuild')
-rw-r--r--dev-python/git-review/git-review-1.25.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/git-review/git-review-1.25.0.ebuild b/dev-python/git-review/git-review-1.25.0.ebuild
new file mode 100644
index 000000000000..f0f1f202d8e3
--- /dev/null
+++ b/dev-python/git-review/git-review-1.25.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}