summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-17 10:04:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-17 10:05:27 -0600
commit4d015de13542befecd26f59ace246020d75ffeab (patch)
treef89d3609662aeb2322fc3a8f5a3785953cdbfc86 /dev-python/git-review
parentsys-apps/mawk: remove sandbox patches (diff)
downloadgentoo-4d015de13542befecd26f59ace246020d75ffeab.tar.gz
gentoo-4d015de13542befecd26f59ace246020d75ffeab.tar.bz2
gentoo-4d015de13542befecd26f59ace246020d75ffeab.zip
dev-python/git-review: 1.28.0 bump
more pythons as well Fixes: https://bugs.gentoo.org/705664 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/git-review')
-rw-r--r--dev-python/git-review/Manifest1
-rw-r--r--dev-python/git-review/git-review-1.28.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/git-review/Manifest b/dev-python/git-review/Manifest
index 440e4f55c155..ab0b38addbfc 100644
--- a/dev-python/git-review/Manifest
+++ b/dev-python/git-review/Manifest
@@ -1,2 +1,3 @@
DIST git-review-1.26.0.tar.gz 56557 BLAKE2B c8af82d7cc222078c1ef470da0ffac7b698df91ed991ba43c8d34a64bbfa3996bdbe475d9965d6d1ef8cca84293613afb92ac6405c0397232e568d2ec2226202 SHA512 74b2366d7884963caaa9b4614301fad56b7997d1cb16ef333cd2dae5df5a5343e5b891fc089078856b57db0083584a8b4ceea98dd67c401651a100fc4fdf7d81
DIST git-review-1.27.0.tar.gz 58471 BLAKE2B baace809949fb5bdb22c6cca251deca7a200b070573840f391ad24ad045276d376616c58355c5159086dc67b481686d6382c71604f2bdc8adf0b2799240a976d SHA512 e9fff7e54457b300c269378062e5bcce28511dfd6662035dc8d276e33e6a0f6b6c68bae98fb3a8a36e468f669c4eeb461e96cdf073a831c42156f8c0ef14fa0a
+DIST git-review-1.28.0.tar.gz 60496 BLAKE2B 19fa2b9a5e2f25d89cf123f277cb0213675e4b99b75a978ee49ee9a394c6f212d5bb58d5e5aee9cc3c20165e9872be159ec81dcf8ea37f509c96bbc79a84bcbd SHA512 c29ad530abcfcf136548daf4865e1fe7c5819f6d4b11424c5c1425312c68fdc0e4073e009667b992e3f3db3396c7db618940c7f6e5be8b26e9d0d1b94fd078a4
diff --git a/dev-python/git-review/git-review-1.28.0.ebuild b/dev-python/git-review/git-review-1.28.0.ebuild
new file mode 100644
index 000000000000..b7d83dac0a48
--- /dev/null
+++ b/dev-python/git-review/git-review-1.28.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"