summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-10-04 09:20:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-10-04 09:21:13 -0500
commit7c3eca00711b8eb53ead3ee6a7614cec6a56c560 (patch)
treebb29aea4b73c2602bf042981c33cae9bf57eb5ee /dev-python/git-review
parentdev-php/pecl-ssh2: Drop old version (diff)
downloadgentoo-7c3eca00711b8eb53ead3ee6a7614cec6a56c560.tar.gz
gentoo-7c3eca00711b8eb53ead3ee6a7614cec6a56c560.tar.bz2
gentoo-7c3eca00711b8eb53ead3ee6a7614cec6a56c560.zip
dev-python/git-review: 1.27.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python/git-review')
-rw-r--r--dev-python/git-review/Manifest1
-rw-r--r--dev-python/git-review/git-review-1.27.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/git-review/Manifest b/dev-python/git-review/Manifest
index 10fb9555ffdb..440e4f55c155 100644
--- a/dev-python/git-review/Manifest
+++ b/dev-python/git-review/Manifest
@@ -1 +1,2 @@
DIST git-review-1.26.0.tar.gz 56557 BLAKE2B c8af82d7cc222078c1ef470da0ffac7b698df91ed991ba43c8d34a64bbfa3996bdbe475d9965d6d1ef8cca84293613afb92ac6405c0397232e568d2ec2226202 SHA512 74b2366d7884963caaa9b4614301fad56b7997d1cb16ef333cd2dae5df5a5343e5b891fc089078856b57db0083584a8b4ceea98dd67c401651a100fc4fdf7d81
+DIST git-review-1.27.0.tar.gz 58471 BLAKE2B baace809949fb5bdb22c6cca251deca7a200b070573840f391ad24ad045276d376616c58355c5159086dc67b481686d6382c71604f2bdc8adf0b2799240a976d SHA512 e9fff7e54457b300c269378062e5bcce28511dfd6662035dc8d276e33e6a0f6b6c68bae98fb3a8a36e468f669c4eeb461e96cdf073a831c42156f8c0ef14fa0a
diff --git a/dev-python/git-review/git-review-1.27.0.ebuild b/dev-python/git-review/git-review-1.27.0.ebuild
new file mode 100644
index 000000000000..039cad47a078
--- /dev/null
+++ b/dev-python/git-review/git-review-1.27.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}