summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-22 12:31:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-22 12:47:08 +0200
commit82eb997a3b676e90f36878ea022bf08123f298ea (patch)
tree47559b515c8f92818a51c6d47b61aa136eb62d9e /dev-python/gitdb
parentdev-python/flask: Bump to 2.1.1 (diff)
downloadgentoo-82eb997a3b676e90f36878ea022bf08123f298ea.tar.gz
gentoo-82eb997a3b676e90f36878ea022bf08123f298ea.tar.bz2
gentoo-82eb997a3b676e90f36878ea022bf08123f298ea.zip
dev-python/gitdb: Bump to 4.0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/Manifest1
-rw-r--r--dev-python/gitdb/gitdb-4.0.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
index f044b27a55a3..0df62ad0ce9d 100644
--- a/dev-python/gitdb/Manifest
+++ b/dev-python/gitdb/Manifest
@@ -1 +1,2 @@
DIST gitdb-4.0.8.tar.gz 394637 BLAKE2B 8eb3b04664df0fb40b93ee814d94a2526d62127c3dd7d0908f8c3ab9c3fc4d7ad368ad6a4288e509ce2f6e43348cb4f3761aaf404040bad1c59bc920517888af SHA512 fa883bf135080a9defa039bf1f13aebdb91c7e8d397c870e24d7c13acc1b30fc32c6299b43c117657382c1908ace748b0967bc53e02c2d73633cc8603fcb8003
+DIST gitdb-4.0.9.tar.gz 394670 BLAKE2B 7882c2757f7c6ff9fa6518504b46ff987fa69f38ba28713a6d140614944e2ccb1c371321402faae835455659a8b33c12523cb781e9c62c79132a724c7ad4d86d SHA512 174b90e09b65ba38d3404fd79a8963987ab49a5e2b96ce82057b519861e8312342c425ff10849c865f66e6e88c27d651d8902a6f8abea88f9f33161f44974109
diff --git a/dev-python/gitdb/gitdb-4.0.9.ebuild b/dev-python/gitdb/gitdb-4.0.9.ebuild
new file mode 100644
index 000000000000..94184a149103
--- /dev/null
+++ b/dev-python/gitdb/gitdb-4.0.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb/
+ https://pypi.org/project/gitdb/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests nose
+
+src_test() {
+ local i
+
+ mkdir "${T}"/repo || die
+ cd "${T}"/repo || die
+
+ for (( i = 0; i < 2500; ++i )); do
+ echo "${i}" > file"${i}" || die
+ done
+
+ git init || die
+ git config user.email "you@example.com" || die
+ git config user.name "Your Name" || die
+ git add -A || die
+ git commit -q -m ".." || die
+ git clone --bare "${T}"/repo "${T}"/repo.git || die
+ cd "${S}" || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ #TRAVIS=1 disables performance tests which rely on the gitdb repo
+ local -x TRAVIS=1
+ local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}