summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:21:39 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:21:39 -0500
commit096fa7779271290a70f66e8992e05d52b5d293f2 (patch)
treef425430aef186983f2ab56f1cacbb3c4b24a8908 /dev-python/glance_store
parentdev-python/python-cinderclient: bup for mitaka (diff)
downloadgentoo-096fa7779271290a70f66e8992e05d52b5d293f2.tar.gz
gentoo-096fa7779271290a70f66e8992e05d52b5d293f2.tar.bz2
gentoo-096fa7779271290a70f66e8992e05d52b5d293f2.zip
dev-python/glance_store: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-0.13.0.ebuild50
-rw-r--r--dev-python/glance_store/metadata.xml2
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index 397625eab3ea..027de191e310 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -1,4 +1,5 @@
DIST glance_store-0.1.10.tar.gz 95520 SHA256 b390fea864f1398f79ab66ce99c3b868b86ac1bf97dbe89ba4498506e2af7d02 SHA512 cd4b2013c49c1104523c809ae28f8cb3fb927564d46db4cb36d5d7c529e69e684af584ad322786e41afc414770a750a545b1baea9f62f2d9611f165df0fc801f WHIRLPOOL d1c65c33eaec3710463fffbe2139fd72b98b3e3e1e722424d8051c0e28c8277e67c96b80476a4245bbd4f2279998b86a6fbd09361d5f73d46f4b80c2eabc5795
+DIST glance_store-0.13.0.tar.gz 126526 SHA256 f3d6ca8f66a290cc31e1420ef9645ed69b36318cfcf86e50c51cbc811dfc8cc3 SHA512 656d6ef6ce13721ece787875273caaf5602699b0d440055d8637793fe987560d2bd3e5b6fc518fad21ae108caf3e549e10eb80ae80f4152d3078b2787d5946ea WHIRLPOOL 20efe459351fef3edb996b9545738da9addc0527d516f38536d70c2d8cc068b0c2a51b8b60d6141d3ad04adc16f273c5b3e7a4e9998318d756c08f4590c4eb92
DIST glance_store-0.4.0.tar.gz 103982 SHA256 cd15e9f9a08dc8d3eeaa452682c8e53423f848eaadf064c0ee8068583aa31154 SHA512 d69337a7f5b06b70ee9ff60e1672d0b16b1fb4e22a38939929df0a6b08f03f0954d60b3ffb747ed30510bca451421f3e5b7133aa574d5786e1b2ba43a80075bd WHIRLPOOL f6685e80e7cce7586a0ecf0af13b1366c1f3fa739571b4f209cf76074742031858f73335c9236806c54a03fb80ccad0c302f1ef6068baa6f6285ac73b708637c
DIST glance_store-0.5.0.tar.gz 106922 SHA256 bb088cea0f83d3335191174b3fbdd5f5b2a39ae4f6e0739b9159e883658657db SHA512 e9f036c9f19ca2f3b8ba82a288a6402c91d849409f4594c61c59c14c8575b5827cf8e072c4772f5ef610fd186037b2d3c5cbc5fb032ca02c025e58a6a59a2dfa WHIRLPOOL 1943b6a26e96a9043b99d6d9b8c9af78468d05f825812250f7c7c396977d4e76d9370fe0c3fd2043d67d519c53c5e11c7541ae4f0389179b61e083f059cc5aea
DIST glance_store-0.6.0.tar.gz 106047 SHA256 249c99818f7ebd1b3aea6c96a66e4e17351a1d9befaef885dada0483be6ee818 SHA512 065c3d68b67ce38a82f8eba29630f368bc723f2c6a34ed1c7adb2ab90f5d24c1b7f32a55c200e5b45167b26bd4d3dae5194484e9de17286cdd91685898276388 WHIRLPOOL c4553654288dc2f3f823a7fbde4ff4c2f1c97b704ff3f55069153819da64ffeb06380975a80db08a1dd33cbbc25418e233b1eadc2aee5569d125223efde69e4c
diff --git a/dev-python/glance_store/glance_store-0.13.0.ebuild b/dev-python/glance_store/glance_store-0.13.0.ebuild
new file mode 100644
index 000000000000..a63c9bfa2ff0
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+cinder"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+ dev-python/enum34[$(python_gen_usedep 'python2*'),$(python_gen_usedep 'python3_3')]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i '/ordereddict/d' requirements.txt
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/glance_store/metadata.xml b/dev-python/glance_store/metadata.xml
index 0cf6ddcae849..b55504898d8a 100644
--- a/dev-python/glance_store/metadata.xml
+++ b/dev-python/glance_store/metadata.xml
@@ -10,7 +10,7 @@
<name>Openstack</name>
</maintainer>
<longdescription lang="en">
- A simple connector pool for python-ldap.
+ Glance's stores library
</longdescription>
<upstream>
<remote-id type="pypi">glance_store</remote-id>