summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-06 08:24:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-06 09:16:03 +0200
commit14bf06b87cb09635bc79a0873e0d09f32d88106a (patch)
treeade8dfa89bed0d9ba4f725e9fe1c9bb117e8bd2b /dev-python/google-api-core
parentdev-python/werkzeug: Bump to 2.0.2 (diff)
downloadgentoo-14bf06b87cb09635bc79a0873e0d09f32d88106a.tar.gz
gentoo-14bf06b87cb09635bc79a0873e0d09f32d88106a.tar.bz2
gentoo-14bf06b87cb09635bc79a0873e0d09f32d88106a.zip
dev-python/google-api-core: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index ad5fdf226719..74deca19215b 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1 +1,2 @@
DIST google-api-core-2.0.1.tar.gz 134658 BLAKE2B 0fda61be3b069454b305656f7a5a9243467f4e129e2db661e997fde850d416a50df803af6e7e9d041b8473e5f1abd35f6d5a9b25067133be28bed90ec1cca7e4 SHA512 297af05cba4919423e15844ccddb821fd65076f787bd01f24022d8393fbf45cf276611ab471be17950d7fad4e58f9b823517a8aeeec931df5b1bb37c38fe8ec9
+DIST google-api-core-2.1.0.tar.gz 138173 BLAKE2B 3ba5b5433a8a29ddf180315daed5587d113bde410697eb5f90713573f41b15b89f0a52e387515751c7702008b150ccc8b90cd7480ac0a26a5f9c73f94443915a SHA512 67688f2defa00df8039d964edeb2cb94aeab5124794fe95d1cba8b9e79aa57b7a191a4b51f91c7d7e293c7a550130cac294926552e47545a0f8222003d0ba076
diff --git a/dev-python/google-api-core/google-api-core-2.1.0.ebuild b/dev-python/google-api-core/google-api-core-2.1.0.ebuild
new file mode 100644
index 000000000000..6e1d986b70c6
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/grpcio-1.33.2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO: package proto-plus
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore_with_nesting
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}