summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 00:48:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 00:51:38 +0200
commit1b733bba4d9ba3baa6eed6049018f7ac52401756 (patch)
tree03bae52950b41b82d6382d0f4fafc371d1b480ff /dev-python/google-api-core
parentdev-python/google-auth: Bump to 1.30.2 (diff)
downloadgentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.tar.gz
gentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.tar.bz2
gentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.zip
dev-python/google-api-core: Bump to 1.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-1.30.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 575a88003575..9d97412fe442 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -2,3 +2,4 @@ DIST google-api-core-1.26.3.tar.gz 133409 BLAKE2B ca3c63769f87cc79483d5ac52646cb
DIST google-api-core-1.27.0.tar.gz 134035 BLAKE2B be074208ac51b6e33466a2304e5780894d6a420ccf7ea36e5b98b6d9f920cd6f0cc9f94dababb154731ebe4a36d8b863897f5c654e00068a0f12753ceecb6e8c SHA512 5e8ca58c7f1dc9aa3e612ea635feb84a115c0f21bde2a3152cd54be5b041841ab1c0d2c725660794e15d42e63a4b6955a5318d3dec20bbbb3e7d683c630a5f5e
DIST google-api-core-1.28.0.tar.gz 133640 BLAKE2B 8134e39cc3ff2fbb850d5e774d08589e3e64b83ca5d5209279f5d1b7fc2eb350a523bbe2890fba6d907689149df3872a7e0a11991b1ecc62fc64a4753dce38e4 SHA512 3702d27613e621394209047451729c1308beb88c917033b4340e3fa96bf4a5ec36ad2594c98ed14439c578f69a202d95a96d30472438a30417484cff6e06fe7d
DIST google-api-core-1.29.0.tar.gz 134251 BLAKE2B 46455f34ad18bd57b21afe70b237466a51d5dbaca8f46f31491d00fcc7e6339fcf48e150418ef71100a628245cc5333984e6377e27eec00b9b55e0c1a3de86e2 SHA512 b8a7b19ba737172e04c0a322af7c60299b72002b17a099fbaa9445c4965b94fd6f3087380fa4262f4440113af4304d5235cd062f22c27cd997e62b276ea67471
+DIST google-api-core-1.30.0.tar.gz 134595 BLAKE2B 104f52bafb68fd91904c02cbd6d3dd2e32c160a528f58e9af3612fc4f7a9934c522f79895b50982b46ee77947af7eb52557bf304b6f2624b97b5082905511829 SHA512 cc14f9c67bac99290665e2b85a97eacf43cdd2a0e4668ecbc7dd8e7131a7e4e908aca2be6d65797d0838081a02768354703762a1a80fa0b666efb81448b27899
diff --git a/dev-python/google-api-core/google-api-core-1.30.0.ebuild b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
new file mode 100644
index 000000000000..1b0c182a7a3c
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}