summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 21:12:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 21:27:08 +0100
commita0d2848bd4db055617d50c932d9201ef7323aaaf (patch)
tree8f0b19251d2baeb608165a73f02a64565eb1ff40 /dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild
parentdev-python/importlib_resources: Bump to 5.1.2 (diff)
downloadgentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.tar.gz
gentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.tar.bz2
gentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.zip
dev-python/google-auth-httplib2: Bump to 0.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild')
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild
new file mode 100644
index 000000000000..8998da238e38
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="google-auth-library-python-httplib2"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/ https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest