summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-09 16:41:46 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-09 16:41:46 -0700
commita164bb1255393ecc3ae850529ffd3a9fbd88f223 (patch)
tree3194c4c6c3385d42db400cac465b0e3491cac812 /dev-python/google-auth-httplib2
parentdev-python/google-api-python-client: PYTHON_COMPAT+=(python3_9) (diff)
downloadgentoo-a164bb1255393ecc3ae850529ffd3a9fbd88f223.tar.gz
gentoo-a164bb1255393ecc3ae850529ffd3a9fbd88f223.tar.bz2
gentoo-a164bb1255393ecc3ae850529ffd3a9fbd88f223.zip
dev-python/google-auth-httplib2: Bump to version 0.0.4
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest1
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.0.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 538eb7463592..945b2caad2e4 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1 +1,2 @@
DIST google-auth-httplib2-0.0.3.tar.gz 10914 BLAKE2B 20473182a5bd4633d1ae16101d81520ddf182706d478c066e533a2eac3e28fccf2bbaf733eeb4f7ea14d658fe29b9b0c656307bb555aabd2d1a21585e3e3d3ba SHA512 dc39626961dfc67ee56d1c74b4e37e6c6a81ec3c8ddcc24007535acc6a973f2cba5e65a9ece323f53d4dcb4f7bca948d65bde4ab55b2c002432d020cba9d914e
+DIST google-auth-httplib2-0.0.4.tar.gz 11218 BLAKE2B a6f4b4cf29ba6db81d70dda16eef7c2d378cf1c38d1f3f2f27a38a7d293809a23a4ae38ef0515b8b1ce278bdfc4a15daa291cac0a70f7a84cf7c8f40e36e01c5 SHA512 a33e54d07c610dcb1e01118808792c3a259b7f1a579acbe3f92825ad5100b96a844168bb37327e71f078b870f1594b021d59d0c86c15868384f19ddb569b42cb
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.4.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.4.ebuild
new file mode 100644
index 000000000000..24f6b0bda716
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="google-auth-library-python-httplib2"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/ https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+# PyPi tarball is missing unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}