summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 18:50:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 19:24:30 +0100
commit639447142ec47a3e7057f357b4f3df90486d2457 (patch)
tree74377a2936b29252c6dd2434da83899913242a68 /dev-python/google-auth-oauthlib
parentdev-python/sphinx-tabs: Bump to 3.3.0 (diff)
downloadgentoo-639447142ec47a3e7057f357b4f3df90486d2457.tar.gz
gentoo-639447142ec47a3e7057f357b4f3df90486d2457.tar.bz2
gentoo-639447142ec47a3e7057f357b4f3df90486d2457.zip
dev-python/google-auth-oauthlib: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 4cf722bb0993..f352686fa497 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-library-python-oauthlib-0.4.6.gh.tar.gz 50982 BLAKE2B 93980a69777089125bca9f583cae0b64f9facf699da3ac135561a9cf135122d9e22a6c0be3325d366dd77a2240fb16d5c63633a216cfee07b9fceb2239227c86 SHA512 a20a85c073a6208d72c8f6ceb34544241f599e716b1191bfc52bcc367797efc18d0e2b94d4e433cec692282b00428bcb4d7e73ed48a26e66d6005189d5dddb77
DIST google-auth-library-python-oauthlib-0.5.0.gh.tar.gz 52118 BLAKE2B 596f9af156030b0dbc0a35c3946ab865370fa326176fc33b04d55aa5d99950718d275f69b399d9afe303ee84f9c5823571eb4c144353f17fe6a64bbca7a35e18 SHA512 7da0d1c5e8c20aee843798c317a2c1edd29caf98abaf8895e354e20279c45395de4a522e21f11dbbe9e67c3bd984ded101b0cde04519b9256d80bdc42501a71a
+DIST google-auth-library-python-oauthlib-0.5.1.gh.tar.gz 53101 BLAKE2B 2edaad7dbe42834d440bb30bcf836e01a575616160af045844da6c853f93a3a7a1c80367bbe58d47dbbdaf9e5b061abf780d9edd48f311e30d79025c934c3764 SHA512 628da0161739c9f0ba5963db6f21da71fde01ff81340d9242adcc74468c92c290693cfa4d98affed79556299621e74083992b54346c14940c1e88c5a5c683408
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild
new file mode 100644
index 000000000000..4a1afbdaab4a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest