summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 09:28:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 09:49:42 +0200
commit897c6cb664377d9cfa295680d26bd4e61b0938ed (patch)
tree0e7b99866ee6f0872498250ac39dbd3777872e67 /dev-python/google-auth-oauthlib
parentdev-python/breathe: Bump to 4.28.0 (diff)
downloadgentoo-897c6cb664377d9cfa295680d26bd4e61b0938ed.tar.gz
gentoo-897c6cb664377d9cfa295680d26bd4e61b0938ed.tar.bz2
gentoo-897c6cb664377d9cfa295680d26bd4e61b0938ed.zip
dev-python/google-auth-oauthlib: Bump to 0.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 382e5fd6b3b3..1106f6f5c541 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-library-python-oauthlib-0.4.3.gh.tar.gz 48020 BLAKE2B bc5e575f3eb7b8b876deb13aaff0d1b900555bcbc609259dc72c9f01f595283feffea6aaaf91acf835b313629fe4c4c76dee8ea877b6ae37c3c01633c63909e4 SHA512 f6fa0e525b0aef6f4359954cb2c8020ee86544862318721d439d153cae3e75527b0e0a312572dc936fab7702da8c6af42ce9242d1e73f48c0a822973e470a4a9
+DIST google-auth-library-python-oauthlib-0.4.4.gh.tar.gz 48322 BLAKE2B f812b43e1e867090aa3ae4fbda7523324a182f6e1eae39fd865d23279b04cde08ee2263b83d1c2eb3555a8db3a9b01869d8148c0e603ba8fe9698dc8d052fc11 SHA512 5b17ceccca24216a0354513ae2a1b14f2aab9760e0ff0f87840a64de85a730a4115f5e44b359093f4ab0a9ec8fea41bfffb7b5aeca833574419ea6021a382240
DIST google-auth-oauthlib-0.4.1.tar.gz 18687 BLAKE2B 1c9028f6b4c306bbee51fba5b55950d129d56ff5154645a166998c0c720b125202731f1cfed60837b8103d56fcdeeb818e39491b243a8d761969f73d9f88f67b SHA512 123707139353db8e05c81138af834e35007d323f0e19ae79088ad5ca4be86dda6c0df91e2f7794711475227a60312fab9101c91b49817bf8b84866ea6374c943
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.4.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.4.ebuild
new file mode 100644
index 000000000000..188128c194b9
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+DOCS=( LICENSE README.rst )