summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-27 08:39:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-27 09:08:14 +0200
commit0fcc3e5d1af6e2fc860036bbbb5692f8abf81837 (patch)
treeca9bbd1954ff4d5994d65ca64ff5674633c9641a /dev-python/google-auth
parentdev-python/boto3: Bump to 1.17.58 (diff)
downloadgentoo-0fcc3e5d1af6e2fc860036bbbb5692f8abf81837.tar.gz
gentoo-0fcc3e5d1af6e2fc860036bbbb5692f8abf81837.tar.bz2
gentoo-0fcc3e5d1af6e2fc860036bbbb5692f8abf81837.zip
dev-python/google-auth: Bump to 1.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.30.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index f616ba6d86e4..a5c70014524c 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-1.28.0.tar.gz 158266 BLAKE2B 7e1fcdd0a6d155c0170012d43062fa5df2c9dd731105990af6d055c0dc8f9c36917776876a25caedd4b804acf24cdebd93a0953a9f7642563a5abc05cc946156 SHA512 a02db23132950c99e032d8318451cd67127f1e9fc57731a8a76505a360d77484aef1859e54d8e4efa1bcde3f6f5379c3324d54cf57c0a95fb1fa7765f43e9581
DIST google-auth-1.28.1.tar.gz 158294 BLAKE2B 3b6e7e746a10fee3f2fcbe1003fa3f5ea94582d092da32e44d8b9772babfb4db321780d1c4253f212971603d0e1212d10fc24dca10c3978faf06bfd8d9a96532 SHA512 e07dac8c0e9814d10bd53302c19cc37339b31141cc20c9fc7b6de8656abd68225f9a7c5502a8c64527c9bdaadd4158b7fa29e5564d02e878ee9acb3d9605c15a
DIST google-auth-1.29.0.tar.gz 167058 BLAKE2B 0c6c9ac11330e46757bc554f7ae984d4ab94562e4524e0c579c0878fb093201240ebabc3a4f44f8d9f530a82ad5f84dd76100d57e2f874b78315c7f0d2cfb4fd SHA512 a6c8ca93ef493f16b7b16c2e1456891a09635bbc4a39053dc2c4cdca2f739692a74e4588c61c8aa5f06c1a5355ef304771770e26f1656edc0ef4c3c291df796d
+DIST google-auth-1.30.0.tar.gz 169598 BLAKE2B 4b0a0e66255abc11c697ca2c3d77ea0b7cf72cc13f6b1630307018e6ea52bda57a1f856787394455d71c61b58103d4e5e24da62f6ffd95022042b48842efcbbe SHA512 d07d6946635071e601c684a60e99ecec532ec51425aa934ece48b124419cb4c69c7651505018471431a7cf14470f4f8d894a2121999d3a482d603d41e5a8e66c
diff --git a/dev-python/google-auth/google-auth-1.30.0.ebuild b/dev-python/google-auth/google-auth-1.30.0.ebuild
new file mode 100644
index 000000000000..5b5858f61e13
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.30.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}