summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:30 +0200
commit783871d3ae180bec38231c633fd2dcdb47347442 (patch)
tree3d6879bdb4f7c12540907be110aed293e31747d1 /dev-python/google-reauth-python
parentdev-python/google-pasta: Remove redundant versions (diff)
downloadgentoo-783871d3ae180bec38231c633fd2dcdb47347442.tar.gz
gentoo-783871d3ae180bec38231c633fd2dcdb47347442.tar.bz2
gentoo-783871d3ae180bec38231c633fd2dcdb47347442.zip
dev-python/google-reauth-python: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-reauth-python')
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild
deleted file mode 100644
index e3130158a0dd..000000000000
--- a/dev-python/google-reauth-python/google-reauth-python-0.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based U2F host library"
-HOMEPAGE="https://github.com/google/google-reauth-python"
-SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
-
-python_prepare_all() {
- sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
- -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
- -i tests/test_reauth.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v tests || die "Tests failed under ${EPYTHON}"
-}