summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/graphy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/graphy')
-rw-r--r--dev-python/graphy/Manifest1
-rw-r--r--dev-python/graphy/graphy-1.0-r1.ebuild50
-rw-r--r--dev-python/graphy/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/graphy/Manifest b/dev-python/graphy/Manifest
new file mode 100644
index 000000000000..a9d274180e49
--- /dev/null
+++ b/dev-python/graphy/Manifest
@@ -0,0 +1 @@
+DIST graphy_1.0.tar.bz2 69099 SHA256 d51c726c7deb028304fe4745afebd5e4fcd012ef2ee214d971f902f5d321492b SHA512 39b85b21dd0e984a3b7895a090d6676d2fc12e629bcb5f2e486ad02b6cacdd57ab150c1aa4364cae571cd8e6fbca20b5744c079be532b6f4ea2668899c9932e3 WHIRLPOOL 1898814373bfcaf9f3e0ad2cd7441a2c23d1f279d573a4db389af8ca1b5154cc5dca40930362161d7f36b51292c53877a1d015550954c3956883ebea6548565c
diff --git a/dev-python/graphy/graphy-1.0-r1.ebuild b/dev-python/graphy/graphy-1.0-r1.ebuild
new file mode 100644
index 000000000000..8fc80588f60a
--- /dev/null
+++ b/dev-python/graphy/graphy-1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Simple Chart Library for Python"
+HOMEPAGE="http://code.google.com/p/graphy/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ esvn_clean
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ :
+}
+
+python_test() {
+ local PYTHONPATH
+ mkdir -p "${BUILD_DIR}"/lib || die
+ cp -r graphy "${BUILD_DIR}"/lib/ || die
+ "${PYTHON}" "${BUILD_DIR}"/lib/graphy/all_tests.py \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_domodule graphy
+ python_optimize
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/graphy/metadata.xml b/dev-python/graphy/metadata.xml
new file mode 100644
index 000000000000..d0b46a26e2cd
--- /dev/null
+++ b/dev-python/graphy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">graphy</remote-id>
+ </upstream>
+</pkgmetadata>