summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-29 18:40:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-29 18:40:39 -0700
commitb2fb2afb7f6400541daef81e986cb5eece23ea7b (patch)
treeec80fd56c8a505373c70efdb3865582827139cdd /dev-python/grpcio
parentnet-libs/grpc: add 1.38.0 (diff)
downloadgentoo-b2fb2afb7f6400541daef81e986cb5eece23ea7b.tar.gz
gentoo-b2fb2afb7f6400541daef81e986cb5eece23ea7b.tar.bz2
gentoo-b2fb2afb7f6400541daef81e986cb5eece23ea7b.zip
dev-python/grpcio: add 1.38.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.38.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index edb4c1b7aa59..f46500fde601 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,2 +1,3 @@
DIST grpcio-1.32.0.tar.gz 20809917 BLAKE2B e28cb44d09fd775b9b6dc87dcd52bf7f144643b09912ff8b76bf39cb250743f90bc7e3769252d47f205f9532157ae68b6ac0a9202158cb14e7b9ad448d951656 SHA512 f802a7b83bd166502fdcbfaf162652adcda36da1b2e91b5073e3b3d97d38191fe989a6dcbec6c1bf27fff162633e54bdbdb20a92e74e14280fac4576baa92157
DIST grpcio-1.37.1.tar.gz 21678919 BLAKE2B ea1c9a1ce1d888d0e9aca27a9e12ebcaca5c79b6f70a282e4e9a12a4aba982c2cef3f755cc2e789de2302071ce3abf12c91f329febd04159b3c8abded96818d5 SHA512 e7697a6d0da40b7d63be7f4f31223d2314bf16fcab8887a41bc4750c844a58ad55fd27fca0a9f1016fc725076a16c3b2db5a9eb040a86a2acb9f45083835d90e
+DIST grpcio-1.38.0.tar.gz 21391828 BLAKE2B efbbf42ad4e67a2c39369c47f345b2a823427341f3e535737d28ff4061941bc649bca179cab84ff5457bab2ccef49146fd2cf7daeb0cae7303e47f192f250feb SHA512 7def460f1a96df65b99fae8aa149428286002aecd14242f62885622fda1568f2d44fc69c3bea28cd1568e3eaa46f03b0fbfda2a9cee23e1e5dfb44ac99ffe597
diff --git a/dev-python/grpcio/grpcio-1.38.0.ebuild b/dev-python/grpcio/grpcio-1.38.0.ebuild
new file mode 100644
index 000000000000..9a037a3b070e
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.38.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-libs/re2-0.2021.04.01:=
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ # os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
+ export GRPC_BUILD_WITH_BORING_SSL_ASM=
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_WITH_SYSTEM_RE2=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}