summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 21:02:19 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 21:04:18 -0800
commitc22eeb47ee0649637cc6ecd9357f0f3a9241d6ed (patch)
treecde809540724a3334caa85b1ab3ab8799b347aa1 /dev-python/grpcio
parentnet-libs/grpc: add 1.43.0 (diff)
downloadgentoo-c22eeb47ee0649637cc6ecd9357f0f3a9241d6ed.tar.gz
gentoo-c22eeb47ee0649637cc6ecd9357f0f3a9241d6ed.tar.bz2
gentoo-c22eeb47ee0649637cc6ecd9357f0f3a9241d6ed.zip
dev-python/grpcio: add 1.43.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.43.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 1e0aeb1f7f64..78a9fd483571 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1 +1,2 @@
DIST grpcio-1.41.1.tar.gz 21241107 BLAKE2B 28600650352c92e215c9cfa150e73835b4dff3946628192bff7f5848c5e2600c37f563c7d1403fb119bebbdcaef4f5e36ac43c4f8609a8338983978501bc21f9 SHA512 555ab9e2524108efb60ec957d419e80e4abc07752bbd265cd1dee5ccd7c55141d9f2f88db6ba5c03d606e266cd72e4650d38316215da8d70358dad971be52fff
+DIST grpcio-1.43.0.tar.gz 21461955 BLAKE2B 406a341d24bf418a006b3f86c25254f3bb3981fd20123fd2d99d53d73e04b8da5500b7d871d8e3d96d1167a1306fd66a05cff418d1af8ff3eba9bb3faa34a199 SHA512 c4e9c7d20e53653c014d3c301f572df26ae84beb8d04fc3d763afcb695d232416ed8e7822f93bed1f9d8aab44f08aaaf36bf2f05aaa6bc3607428efbc0775cb1
diff --git a/dev-python/grpcio/grpcio-1.43.0.ebuild b/dev-python/grpcio/grpcio-1.43.0.ebuild
new file mode 100644
index 000000000000..1ad2f3d376ce
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.43.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/openssl-1.1.1:0=[-bindist(-)]
+ >=dev-libs/re2-0.2021.11.01:=
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/1.37.1-cc-flag-test-fix.patch" )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ # os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
+ export GRPC_BUILD_WITH_BORING_SSL_ASM=
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_WITH_SYSTEM_RE2=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}