summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 08:06:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:32:02 +0200
commiteafd93b968ab44c9fc2811c94a6ae7d6eefa1e73 (patch)
tree31cd3d2e96956d2a276060fa1aaee27dd01174fc /dev-python/gsd
parentdev-python/xlsxwriter: Bump to 1.3.9 (diff)
downloadgentoo-eafd93b968ab44c9fc2811c94a6ae7d6eefa1e73.tar.gz
gentoo-eafd93b968ab44c9fc2811c94a6ae7d6eefa1e73.tar.bz2
gentoo-eafd93b968ab44c9fc2811c94a6ae7d6eefa1e73.zip
dev-python/gsd: Bump to 2.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.4.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 9017b86e0366..1372a74869b4 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1,3 +1,4 @@
DIST gsd-v1.5.3.tar.gz 240114 BLAKE2B 076d888f03350fba2388c907787354e878a1536c7d85c759eb3513102ee2abffe2c9313a6e9e208726d66d6324dac02ae70d8872342f9bcb162ad13d9a23dbc3 SHA512 893db74dc481da47d6c51ea0d0d9faefbe164edfaeb5a2ed73e25acbd9dc42c3cf28cbc0d9257c6bf0cc0e9911ab85cfa72997886350c0e7c125d30636ec432a
DIST gsd-v2.4.0.tar.gz 112743 BLAKE2B d35a1108cb12f58f8b6cc980c156ae2dceb0c0d2c4d41d35ae29bae1bc342654e148616e64a6dfcb07bdbb1156299d8d05914d028dfb877979c8a17f299feb06 SHA512 47e136018d813f48c5d78cc31786a5bb33992f488a4d907b450a570bb90f9ffeb233e82f9686d09aeb3541fca1518294d5bf63c6a896635f30ad369350012458
DIST gsd-v2.4.1.tar.gz 113343 BLAKE2B 5d87fe5dbac037aeccf2ef800fc18accb1888606ed904b15910480032edaaa21bed3adf264e17ea5dc42f6600321c838c15e73617a1d8f49fb9a8e5e79a0bff4 SHA512 47982500160dc2a125ae2d796fccb1fb31fa501f059c8dee9be1342713d62e3d6ce71b534dbc91daedbf6981299efa4b81382afa13283d647c0848bbd3591c91
+DIST gsd-v2.4.2.tar.gz 111622 BLAKE2B a4e08cc03ced2158818cf35e3f827d819b2248de52a21060e06a8d47810e2cf80fc25c9033c8b231b58c723ae794b9066261fdfcc5d19713a916ec9aa31adddc SHA512 8db05903bfcfc45bf1ffc326ffe67ce4d980a2b91596256fa29d006c73f742ac69b829ea2f4b7e1508bf5279c584fd66316e2e0776236bdce791e2cb46093ed3
diff --git a/dev-python/gsd/gsd-2.4.2.ebuild b/dev-python/gsd/gsd-2.4.2.ebuild
new file mode 100644
index 000000000000..b121fb8f35c3
--- /dev/null
+++ b/dev-python/gsd/gsd-2.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://github.com/glotzerlab/gsd"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND=${DEPEND}
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ epytest gsd/test
+ rm -rf .pytest_cache .hypothesis || die
+}