summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-04-05 18:11:59 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-04-08 23:21:17 +0200
commit9c2f852ed5a8aed3bd33557c99ea79680d967bfe (patch)
treeb06436418ce951e37a1bd6a7fbaba4aa2104e315 /dev-python/guessit/guessit-2.1.2.ebuild
parentdev-python/guessit: switch live ebuild to 'develop' branch. (diff)
downloadgentoo-9c2f852ed5a8aed3bd33557c99ea79680d967bfe.tar.gz
gentoo-9c2f852ed5a8aed3bd33557c99ea79680d967bfe.tar.bz2
gentoo-9c2f852ed5a8aed3bd33557c99ea79680d967bfe.zip
dev-python/guessit: version bump to 2.1.2.
Closes: https://github.com/gentoo/gentoo/pull/4365 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/guessit/guessit-2.1.2.ebuild')
-rw-r--r--dev-python/guessit/guessit-2.1.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/guessit/guessit-2.1.2.ebuild b/dev-python/guessit/guessit-2.1.2.ebuild
new file mode 100644
index 000000000000..409fd7259eb1
--- /dev/null
+++ b/dev-python/guessit/guessit-2.1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.python.org/pypi/guessit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-0.8.2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}