summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-09-09 00:54:02 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-09-14 21:01:08 +0100
commitaa7fde1c8edf3d2da3c612b44dc1e7227e3014c9 (patch)
tree0f1a3c1490bc2a4b2951d3c5860715a4ef5b2c49 /dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild
parentdev-python/botocore: 9999: add urllib3 to RDEPEND (diff)
downloadgentoo-aa7fde1c8edf3d2da3c612b44dc1e7227e3014c9.tar.gz
gentoo-aa7fde1c8edf3d2da3c612b44dc1e7227e3014c9.tar.bz2
gentoo-aa7fde1c8edf3d2da3c612b44dc1e7227e3014c9.zip
dev-python/guzzle_sphinx_theme: add python3_7, EAPI=7
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild')
-rw-r--r--dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild b/dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild
new file mode 100644
index 000000000000..d18b0f7dc705
--- /dev/null
+++ b/dev-python/guzzle_sphinx_theme/guzzle_sphinx_theme-0.7.11-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx theme used by Guzzle"
+HOMEPAGE="https://github.com/guzzle/guzzle_sphinx_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/sphinx-1.2[${PYTHON_USEDEP}]"