summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 10:13:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:55 +0100
commit7b20dc2122bf8445820f960ae2469ce1605120f3 (patch)
tree063e642b073f962460cc2ae771313573e6ae9ec6 /dev-python/h2
parentdev-python/hpack: Switch to PEP 517 build (diff)
downloadgentoo-7b20dc2122bf8445820f960ae2469ce1605120f3.tar.gz
gentoo-7b20dc2122bf8445820f960ae2469ce1605120f3.tar.bz2
gentoo-7b20dc2122bf8445820f960ae2469ce1605120f3.zip
dev-python/h2: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h2')
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..8b126759708d
--- /dev/null
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="
+ https://python-hyper.org/projects/h2/en/stable/
+ https://github.com/python-hyper/h2/
+ https://pypi.org/project/h2/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/hyperframe-6.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-7[${PYTHON_USEDEP}]
+ >=dev-python/hpack-4.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest