summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-11 12:52:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-11 13:03:22 +0200
commita70cf8bb1d9672e245da57100f4378c39b947c59 (patch)
tree7fb6f4dcad58d8cce7a064b958d6b1140fc7a0d5 /dev-python/h2
parentdev-python/pygments: Enable py3.13 (diff)
downloadgentoo-a70cf8bb1d9672e245da57100f4378c39b947c59.tar.gz
gentoo-a70cf8bb1d9672e245da57100f4378c39b947c59.tar.bz2
gentoo-a70cf8bb1d9672e245da57100f4378c39b947c59.zip
dev-python/h2: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h2')
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
index 7dee9b75abc0..48df5ef3a0e6 100644
--- a/dev-python/h2/h2-4.1.0-r1.ebuild
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -37,17 +37,3 @@ PATCHES=(
)
distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == python3.11 ]]; then
- EPYTEST_DESELECT+=(
- test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
- test/test_events.py::TestEventReprs::test_streamreset_repr
- test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
- test/test_events.py::TestEventReprs::test_connectionterminated_repr
- )
- fi
-
- epytest
-}