summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-03-17 22:13:52 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-03-17 22:13:52 +0700
commitff0d0d519d21d3ee0518b4dbbae5e4af892829b1 (patch)
tree15168d3cde0bbc8ecf4a91c17dbd6fcf3720c9a9 /dev-python/h5py
parentdev-python/iminuit: bump to 1.3.8 (diff)
downloadgentoo-ff0d0d519d21d3ee0518b4dbbae5e4af892829b1.tar.gz
gentoo-ff0d0d519d21d3ee0518b4dbbae5e4af892829b1.tar.bz2
gentoo-ff0d0d519d21d3ee0518b4dbbae5e4af892829b1.zip
dev-python/h5py: add python3_8
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/h5py-2.10.0-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/h5py/h5py-2.10.0-r1.ebuild b/dev-python/h5py/h5py-2.10.0-r1.ebuild
new file mode 100644
index 000000000000..8ae6c9b9c69c
--- /dev/null
+++ b/dev-python/h5py/h5py-2.10.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="https://www.h5py.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# disable mpi until mpi4py gets python3_8
+#IUSE="examples mpi"
+IUSE="examples"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
+RDEPEND="sci-libs/hdf5:=[hl(+)]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="dev-python/pkgconfig"
+# mpi? ( virtual/mpi )
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/alabaster[${PYTHON_USEDEP}] )
+ test? ( dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ dev-python/cached-property[${PYTHON_USEDEP}] )"
+# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
+
+PATCHES="${FILESDIR}/${P}-tests.patch"
+
+DOCS=( README.rst AUTHORS ANN.rst )
+
+distutils_enable_tests setup.py
+distutils_enable_sphinx docs --no-autodoc
+
+#pkg_setup() {
+# use mpi && export CC=mpicc
+#}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+# esetup.py configure $(usex mpi --mpi '')
+ esetup.py configure
+}
+
+python_test() {
+ esetup.py test || die "Tests fail with ${EPYTHON}"
+ # tests generate .pytest_cache which should not be installed
+ rm -r "${BUILD_DIR}/lib/.pytest_cache" || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}