summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 13:09:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 13:09:55 +0200
commita4cf4a7f9d1a9ea0eb425d663e4894687f7093c3 (patch)
tree08884e61b52271fc9a924fabcf10679a79261e77 /dev-python/hatchling
parentdev-python/httpx: Enable pypy3 (diff)
downloadgentoo-a4cf4a7f9d1a9ea0eb425d663e4894687f7093c3.tar.gz
gentoo-a4cf4a7f9d1a9ea0eb425d663e4894687f7093c3.tar.bz2
gentoo-a4cf4a7f9d1a9ea0eb425d663e4894687f7093c3.zip
dev-python/hatchling: Enable tests on pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/hatchling-0.22.0.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/dev-python/hatchling/hatchling-0.22.0.ebuild b/dev-python/hatchling/hatchling-0.22.0.ebuild
index be8f4b765bce..ccb3b007747a 100644
--- a/dev-python/hatchling/hatchling-0.22.0.ebuild
+++ b/dev-python/hatchling/hatchling-0.22.0.ebuild
@@ -35,15 +35,13 @@ RDEPEND="
BDEPEND="
${RDEPEND}
test? (
- $(python_gen_cond_dep '
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- ' 'python*')
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
)
"
@@ -56,11 +54,6 @@ python_compile() {
}
python_test() {
- if [[ ${EPYTHON} != python* ]]; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
local -x EPYTEST_DESELECT=(
# these run pip to install stuff
tests/backend/dep/test_core.py::test_dependency_found
@@ -75,5 +68,5 @@ python_test() {
# and hatchling
cd "${WORKDIR}/${MY_P}" || die
local -x PYTHONPATH="src:${PYTHONPATH}"
- epytest -x tests/backend
+ epytest tests/backend
}