summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-21 23:58:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-22 00:15:00 +0200
commit56bf1c363a484f004d642d736ef22ed71120b275 (patch)
tree9a6599d60e765566aa07e5b0149702f5417d0e3d /dev-python/hcs-utils/hcs-utils-2.0.ebuild
parentdev-python/colorama: version bump. (diff)
downloadgentoo-56bf1c363a484f004d642d736ef22ed71120b275.tar.gz
gentoo-56bf1c363a484f004d642d736ef22ed71120b275.tar.bz2
gentoo-56bf1c363a484f004d642d736ef22ed71120b275.zip
dev-python/hcs-utils: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/hcs-utils/hcs-utils-2.0.ebuild')
-rw-r--r--dev-python/hcs-utils/hcs-utils-2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/hcs-utils/hcs-utils-2.0.ebuild b/dev-python/hcs-utils/hcs-utils-2.0.ebuild
new file mode 100644
index 000000000000..5d17911fb1d5
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="https://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ py.test --doctest-modules hcs_utils || die "Tests failed"
+}