summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-08 18:54:20 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-08 18:54:20 -0700
commit99d071475448abc9d4935da9f2b7b5182bd4a1f5 (patch)
tree8cacb679b5c36aced35fa0b3f82dc8d6c77d0cec /dev-python/html5lib/html5lib-0.999999999.ebuild
parentdev-python/pytest-expect: add package (diff)
downloadgentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.tar.gz
gentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.tar.bz2
gentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.zip
dev-python/html5lib: version bump to 0.999999999
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/html5lib/html5lib-0.999999999.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-0.999999999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-0.999999999.ebuild b/dev-python/html5lib/html5lib-0.999999999.ebuild
new file mode 100644
index 000000000000..6465ee9478e2
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}